Update from ISPCFG3 -> 3.0.2 | myDNS -> BIND

Discussion in 'Installation/Configuration' started by killerwake, Mar 12, 2010.

  1. killerwake

    killerwake New Member

    Hi guys i'm running into a conflict you suggest on this tutorial to install myDNS


    and i installed myDNS and then on this update to 3.0.2 i notice that BIND is used instead of myDNS, and both conflicts because they are DNS servers and use the same tcp port 53. one of them gives the error "tcp already in use: 53".

    So why this change???? what is better????
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no chnage. It looks as if you accidently installed two dns servers on your server, so ispconfig can not decide which one has to be used. To get your setup working again, you have to remove the bind package with the pacakge manager of your linux distribution e.g. yum or apt and then rerun the update script.
  3. killerwake

    killerwake New Member

    ok till i got it! but i had bind and mydns installed but i only enabled mydns, to work with ispcfg, so the update script don't check wich one is running, he tried to run BIND instead of myDNS. it's only a suggestion btw. don't get me wrong :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There are tutorials available that explain the installation of ispconfig, if you follow them, then your system is safe for future updates. You should never install two daemons for the same purpose on a server. This is not specific to ispconfig. So if your server runs mydns, then do not install bind.

Share This Page