update from 3.0.5.4p8 to 3.0.5.4p9

Discussion in 'General' started by heater20, Jul 2, 2016.

  1. heater20

    heater20 New Member

    While trying to update from 3.0.5.4p8 to 3.0.5.4p9 it would fail or stop the update after Creating backup of "/usr/local/ispconfig" directory... and Creating backup of "/etc" directory...! After running /usr/local/ispconfig/server/server.sh I got the following output errors.
    PHP Fatal error: Class 'mysqli' not found in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 31
    PHP Stack trace:
    PHP 1. {main}() /usr/local/ispconfig/server/server.php:0
    PHP 2. require() /usr/local/ispconfig/server/server.php:32
    PHP 3. app->__construct() /usr/local/ispconfig/server/lib/app.inc.php:209
    PHP 4. app->load() /usr/local/ispconfig/server/lib/app.inc.php:45
    PHP 5. include_once() /usr/local/ispconfig/server/lib/app.inc.php:106
    I don't understand the errors and not sure if this is the problem with the update not working. Also noticed that I can not add new websites as well.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    php --version
     
  3. heater20

    heater20 New Member

    Till thanks for your reply, I went ahead and reloaded the system.
     

Share This Page