Update fail

Discussion in 'Installation/Configuration' started by estebanmora, Dec 7, 2011.

  1. estebanmora

    estebanmora New Member

    Hi,

    I tried to update ISPConfig 3 last night asking the web interface to do the job. I found this morning that the interface wasn't working, although the sites were working (i think that the cron jobs crashed). So I tried to update using the shell. When I type ispconfig_update.sh a copy of ISPConfig 3 is downloaded, a lot of files decompressed but the installation crashes saying:

    >> Update

    Operating System: Debian 6.0 (Squeeze/Sid) or compatible

    PHP Notice: Undefined variable: conf in /tmp/ispconfig3_install/install/update.php on line 76

    If I try to update using php -q update.php I receive the same error. I tried to uninstall it but nothing happens.

    Please, help!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. estebanmora

    estebanmora New Member

    Dind't work!

    The failed upgrade caused problems with the mysqld deamon. Mysql was unable to load, so I ended up installing a new server with ISPConfig 3.0.3. I will never try to update it again. :-(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig update does not change anything in the mysql configuration files,so if mysql failed to load, then this was caused by something else. Maybe you installed somelinux system updates too?

    Beside that, why did you use the experimental update function in the interface (which is marked as use for your own risk) instead of using the recommended and mature shell update script as described in the update instructions and ispconfig release notes? The ispconfig update instructions also describe that you shall do a backup of several folders before you update so that you caould easily revert to the old version which you seemed to not have done.

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/
     
  5. estebanmora

    estebanmora New Member

    Where does it says that 3.0.4 is an experimental release? My working copy of ISPConfig 3.0.3 make me know that there is an update and I proceed. Don't worry, lesson learned. Never update!
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Not 3.0.4 is experimental, the interface update button is experimental.

    Correct,and it forwarded you to the ispconfig page where the release notes are posted and these release notes instructed you to run:

    ispconfig_update.sh

    as root user on the shell.

    Might be better: lesson lerned, read the update instructions before you update a software. Why do you think that we publish release notes which contain specific update instructions for every release? A server comtrol panel is a complex software with a lot of dependencies and we inform the users in the release notes on how to update to that release and what to obey when doing the update.
     
  7. estebanmora

    estebanmora New Member

    When I noticed that the web interface screw-up the whole interface I checked the sites and they were working fine. So I try to update using the shell interface as root and and an error appears with the $conf variable. Then I noticed that the mysql deamon was damaged.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason for that error message was the failed update before. The ispconfig configuration file was empty so that the shell script could not find the details of the ispconfig system and stopped to ensure that the system is not damaged more. I posted you the link above on how to recover that. A fresh install was not required.

    This was not caused by the ispconfig update, as ispconfig uses mysql, but is does not configure it. If mysql does not start, then you can finf the reason for that eith.er in the syslog file or mysql log file.
     

Share This Page