Update error

Discussion in 'Installation/Configuration' started by adriaan, Jul 20, 2006.

  1. adriaan

    adriaan New Member

    ISPConfig team,

    When I try to update; I download the new version (2.2.2 -> 2.2.5); and I install it (./setup).
    Your program says it's an upgrade, what is correct. When every thing is done I execute the quota commands, and then I reboot.
    After the reboot the normal servers are running but the ISPConfig Admin doesn't work.
    When I go tho http://domain.tld:100 a get the error 'Go to https://www1.domain.tld:100' (ISPConfig is port 100 (extern)), when I go to https://domain.tld:100 my webbrowser (IE, sorry!) says: 'Cannot find server or DNS Error'.

    Could you tell me where I can set it right? I'm not at home; so I can only use PuTTY (SSH).

    Adriaan, Netherlands
  2. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    try :81 instead of :100, might be that update override the old settings.. Could be wrong tho :)
  3. adriaan

    adriaan New Member

    I'm not at home now. My router forwards port 81 (www1) to 100 (www2 -> 101, etc.)

    So that couldn't be the problem
  4. falko

    falko Super Moderator ISPConfig Developer

    No, you must try port 81 directly on the ISPConfig server. If your router forwards port 81 to port 100, then requests arrive on port 100 on the ISPConfig server whereas ISPConfig is running on port 81 again after the update.
  5. adriaan

    adriaan New Member


    Now i'm at home. And it's not working ;).

    I didn't change anything to the config, and it had worked always...
  6. adriaan

    adriaan New Member

    The solution!

    Now I know how it works:
    1. ./setup
    2. quota
    3. reboot
    So, no reboot after update and before quota. Then you damage your SSL certifacate (Firefox gives this error, IE not.).
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Rebooting is not nescessary when you update ISPConfig and quota has not to be changed.
  8. adriaan

    adriaan New Member

    When I didn't used the quota commands. ISPConfig didn't worked.
    So (on my system) it's important!

Share This Page