Update Debian and IspConfig error curl

Discussion in 'Installation/Configuration' started by Oitsuki, Aug 9, 2019.

  1. Oitsuki

    Oitsuki Member

    hello,
    When I update my debian (buster) and IspConfig, this error Appear and I would know if it's possible to resolve it ?

    sudo apt-get install php7.3-curl
    Reading packet lists... done
    Construction of the tree of outbuildings
    Reading the status information... done
    Some packages cannot be installed. This can mean
    you've asked for the impossible, or if you're using
    unstable distribution, which some packages have not yet
    created or did not come out of Incoming.
    The following information should help you resolve the situation:

    The following packages contain unsatisfied dependencies:
    php7.3-curl: Depends: libcurl3 (up 7.44.0) but it is not installable
    E: Unable to fix problems, defective packages are in "keep it as they are" mode.
     
  2. Oitsuki

    Oitsuki Member

    Whats the best action I must make for that ?
    Thank you.
    Code:
    [email protected]:/tmp# aptitude install php7.3-curl
    Les NOUVEAUX paquets suivants vont être installés :     
      php7.3-curl{b} 
    0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis à jour.
    Il est nécessaire de télécharger 28,8 ko d'archives. Après dépaquetage, 123 ko seront utilisés.
    Les paquets suivants ont des dépendances non satisfaites :
     php7.3-curl : Dépend: libcurl3 (>= 7.44.0) which is a virtual package and is not provided by any available package
    
    Les actions suivantes permettront de résoudre ces dépendances :
    
         Conserver les paquets suivants dans leur version actuelle :
    1)     php7.3-curl [Non installé]                               
    
    Accepter cette solution ? [Y/n/q/?] n
    Les actions suivantes permettront de résoudre ces dépendances :
    
          Installer les paquets suivants :                                                                     
    1)      php7.3-curl [7.3.4-2 (stable)]                                                                     
    
          Réinstaller à une version antérieure les paquets suivants :                                         
    2)      libapache2-mod-php7.3 [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]
    3)      php7.3-cgi [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    4)      php7.3-cli [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    5)      php7.3-common [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]       
    6)      php7.3-fpm [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    7)      php7.3-gd [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    8)      php7.3-gmp [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    9)      php7.3-intl [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]         
    10)     php7.3-json [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]         
    11)     php7.3-mbstring [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]     
    12)     php7.3-mysql [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]         
    13)     php7.3-opcache [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]       
    14)     php7.3-readline [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]     
    15)     php7.3-soap [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]         
    16)     php7.3-sqlite3 [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]       
    17)     php7.3-xml [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)]           
    18)     php7.3-zip [7.3.8-1+0~20190807.43+debian9~1.gbp7731bf (<NULL>, now) -> 7.3.4-2 (stable)] 
    
    
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do
    Code:
    apt-get dist-upgrade
    That should do the upgrade and install missing dependencies and remove packages if needed.
    Or maybe you have packages in hold state? Try
    Code:
    dpkg --get-selections | grep 'hold$'
     
  4. Oitsuki

    Oitsuki Member

    Thank you
    There the result

    Code:
    [email protected]:/# apt-get dist-upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances      
    Lecture des informations d'état... Fait
    Calcul de la mise à jour... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    [email protected]:/# dpkg --get-selections | grep 'hold$'
    ==> nothing
    
     
  5. Oitsuki

    Oitsuki Member

    @till MY Latest news do not appear, I think it's in relation wit curl ? No
    How to change that ? (debian buster)
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Compare your installation with the ISPConfig perfect server for Debian Buster and ensure that you installed and configured your server as described in that guide.
     

Share This Page