update 3.0 to 3.1 on Debian Squeeze

Discussion in 'Installation/Configuration' started by Quax, Aug 28, 2018.

  1. Quax

    Quax New Member

    after Update my ISPconfig 3.0.5 to 3.1.13 with ispconfig_update.sh there are following Problems:
    Message with postfix -M Parameter (seems to be no problem),
    There are no icons visible only Placeholders
    Cannot see the theme Blue in the selection tools interface

    But the bigger Problem:
    In system server configuration i get no access to the configuration register. If I click on the Servername the waiting circle is visible a short time, then it happens nothing (going back to the System Configuration Base with the server name).

    All other functions, what I'm using seems running (web, mail, Usermanagement)


    In which direction can I look for the solution of this Problems

    Thankfull for every help
    Matthias
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Quax

    Quax New Member

    I've cleared caches, I used Browsers which I didn't use before (Opera) With Firefox, Chrome and Opera I don't see the icons, with IE 11 I see Icons (May be a combination of Browser and old apache?)
    But with all this Browsers include the IE I cannot access the server configuration sites (Base configuration IP-adress ...)
    I have looked in logs and found 404 not found. May be some conversion from 3.0 to 3.1 was not finished.
    I have a fresh 3.1 and compared the files and folders. Seems to be the same with both. So I think something with the database.

    Before posting I have checked before this posting too. There are no errors, except it do not show the ip address (Database Problem?)
    ---------------------------------------------------------------------------
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.13


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.3.27-1~dotdeb.0

    ##### PORT CHECK #####

    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 2333)
    [INFO] I found the following mail server(s):
    Postfix (PID 2112)
    [INFO] I found the following pop3 server(s):
    Courier Mailserver (PID 1997)
    [INFO] I found the following imap server(s):
    Courier Mailserver (PID 1969)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 2133)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:3306 (1066/mysqld)
    [localhost]:10026 (917/amavisd)
    [localhost]:10027 (2112/master)
    [anywhere]:587 (2112/master)
    [localhost]:783 (1132/spamd.pid)
    [anywhere]:111 (735/portmap)
    [anywhere]:21 (2133/pure-ftpd)
    ***.***.***.***:53 (875/named)
    [localhost]:53 (875/named)
    [anywhere]:22 (890/sshd)
    [anywhere]:25 (2112/master)
    [localhost]:953 (875/named)
    [anywhere]:58809 (758/rpc.statd)
    [localhost]:676 (2196/famd)
    [localhost]:10024 (917/amavisd)
    [localhost]:10025 (2112/master)
    *:*:*:*::*:587 (2112/master)
    [localhost]10 (1997/couriertcpd)
    [localhost]43 (1969/couriertcpd)
    *:*:*:*::*:8080 (2333/apache2)
    *:*:*:*::*:80 (2333/apache2)
    *:*:*:*::*:8081 (2333/apache2)
    *:*:*:*::*:21 (2133/pure-ftpd)
    *:*:*:*::*:53 (875/named)
    *:*:*:*::*:22 (890/sshd)
    *:*:*:*::*:25 (2112/master)
    *:*:*:*::*:953 (875/named)
    *:*:*:*::*:443 (2333/apache2)
    *:*:*:*::*:993 (1986/couriertcpd)
    *:*:*:*::*:995 (2009/couriertcpd)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-courierauth tcp -- [anywhere]/0 [anywhere]/0 multiport dports 25,465,143,220,993,110,995
    fail2ban-ssh tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-courierauth (1 references)
    target prot opt source destination
    DROP all -- ***.***.***.*** [anywhere]/0
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0
    ----------------------------------------------------------------------------------

    Thank you for your fast reply

    Matthias
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Just verifying, when you updated ISPConfig, you answered yes to reconfigure services?

    Do you have any conf-custom files which need updated?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you use a custom theme in ISPConfig 3.0?
     
  6. Quax

    Quax New Member

    At the time of installation this Installation was a clean installation with the help of perfect server example Squeeze.
    Nothing customized only configured web and mail and ftp services no dns no firewall nothing other.
    Every update within 3.0 runs fine
    Yes I choose reconfigure (I take all default)
     
  7. Quax

    Quax New Member

    Maybe this message in /var/log/ispconfig/httpd/HPISPconfig...../access.log helps to find the config page problem?

    GET /admin/server_config_edit.php?id=1 HTTP/1.1" 500 404
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. Quax

    Quax New Member

    Under requirements of iscponfig 3.1 I found debian 6 (Squeeze)
    The last Debian 6 php Version was 5.3.27 with me.
    Which php Version do I need minimum to get the config running?
    Will this version possible on squeeze?
    I'm now prepare to switch to newer servers, but I need the old running some months further.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    As explained in the bug report, a PHP syntax which is not supported by PHP 5.3 has been used in this file by accident. It will be fixed in the next ISPConfig release. Until then, the only fix is to do what the initial poster of that report did, get the same file from ISPConfig 3.1.12 as a replacement for the one from ISPConfig 3.1.13.
     
  11. Quax

    Quax New Member

    With the server_config_edit.php of Version 3.1.12 the config runs. Thank you very much !!! :)

    The icons aren't so much important, but why do I get Icons on IE 11 but not on other browsers (chaches cleaned ...)
    May be it is a php problem too?
    If it is too complicated I will leave it like it is because up to the end of the year I will have the new servers
     
  12. Quax

    Quax New Member

    About the icons (font) I found following in the firefox:
    {
    "log": {
    "version": "1.1",
    "creator": {
    "name": "Firefox",
    "version": "62.0"
    },
    "browser": {
    "name": "Firefox",
    "version": "62.0"
    },
    "pages": [
    {
    "startedDateTime": "2018-09-18T17:03:44.196+02:00",
    "id": "page_1",
    "title": "ISPConfig",
    "pageTimings": {
    "onContentLoad": 864,
    "onLoad": 2086
    }
    }
    ],
    "entries": [
    {
    "pageref": "page_1",
    "startedDateTime": "2018-09-18T17:03:44.196+02:00",
    "request": {
    "bodySize": 0,
    "method": "GET",
    "url": "https://192.168.0.39:8080/themes/default/assets/fonts/ispconfig.woff?-drlkxz",
    "httpVersion": "HTTP/1.1",
    "headers": [
    {
    "name": "Host",
    "value": "192.168.0.39:8080"
    },
    {
    "name": "User-Agent",
    "value": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
    },
    {
    "name": "Accept",
    "value": "application/font-woff2;q=1.0,application/font-woff;q=0.9,*/*;q=0.8"
    },
    {
    "name": "Accept-Language",
    "value": "de,en-US;q=0.7,en;q=0.3"
    },
    {
    "name": "Accept-Encoding",
    "value": "identity"
    },
    {
    "name": "Referer",
    "value": "https://192.168.0.39:8080/themes/default/assets/stylesheets/fonts.min.css"
    },
    {
    "name": "Cookie",
    "value": "PHPSESSID=p13l1ur5734vhh9ckrua27ofl4"
    },
    {
    "name": "Connection",
    "value": "keep-alive"
    },
    {
    "name": "Cache-Control",
    "value": "max-age=0"
    }
    ],
    "cookies": [
    {
    "name": "PHPSESSID",
    "value": "p13l1ur5734vhh9ckrua27ofl4"
    }
    ],
    "queryString": [
    {
    "name": "-drlkxz",
    "value": ""
    }
    ],
    "headersSize": 510
    },
    "response": {
    "status": 403,
    "statusText": "Forbidden",
    "httpVersion": "HTTP/1.1",
    "headers": [
    {
    "name": "Date",
    "value": "Tue, 18 Sep 2018 15:03:45 GMT"
    },
    {
    "name": "Server",
    "value": "Apache/2.2.16 (Debian)"
    },
    {
    "name": "Vary",
    "value": "Accept-Encoding"
    },
    {
    "name": "Content-Length",
    "value": "244"
    },
    {
    "name": "Keep-Alive",
    "value": "timeout=15, max=86"
    },
    {
    "name": "Connection",
    "value": "Keep-Alive"
    },
    {
    "name": "Content-Type",
    "value": "text/html; charset=iso-8859-1"
    }
    ],
    "cookies": [],
    "content": {
    "mimeType": "text/html; charset=iso-8859-1",
    "size": 244,
    "text": "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>403 Forbidden</title>\n</head><body>\n<h1>Forbidden</h1>\n<p>You don't have permission to access /themes/default/assets/fonts/ispconfig.woff\non this server.</p>\n</body></html>\n"
    },
    "redirectURL": "",
    "headersSize": 240,
    "bodySize": 484
    },
    "cache": {},
    "timings": {
    "blocked": 2,
    "dns": 0,
    "connect": 0,
    "ssl": 0,
    "send": 0,
    "wait": 2,
    "receive": 1
    },
    "time": 5,
    "_securityState": "secure",
    "serverIPAddress": "192.168.0.39",
    "connection": "8080"
    },
    {
    "pageref": "page_1",
    "startedDateTime": "2018-09-18T17:03:44.539+02:00",
    "request": {
    "bodySize": 0,
    "method": "GET",
    "url": "https://192.168.0.39:8080/themes/default/assets/fonts/ispconfig.ttf?-drlkxz",
    "httpVersion": "HTTP/1.1",
    "headers": [
    {
    "name": "Host",
    "value": "192.168.0.39:8080"
    },
    {
    "name": "User-Agent",
    "value": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
    },
    {
    "name": "Accept",
    "value": "application/font-woff2;q=1.0,application/font-woff;q=0.9,*/*;q=0.8"
    },
    {
    "name": "Accept-Language",
    "value": "de,en-US;q=0.7,en;q=0.3"
    },
    {
    "name": "Accept-Encoding",
    "value": "gzip, deflate, br"
    },
    {
    "name": "Referer",
    "value": "https://192.168.0.39:8080/themes/default/assets/stylesheets/fonts.min.css"
    },
    {
    "name": "Cookie",
    "value": "PHPSESSID=p13l1ur5734vhh9ckrua27ofl4"
    },
    {
    "name": "Connection",
    "value": "keep-alive"
    },
    {
    "name": "Cache-Control",
    "value": "max-age=0"
    }
    ],
    "cookies": [
    {
    "name": "PHPSESSID",
    "value": "p13l1ur5734vhh9ckrua27ofl4"
    }
    ],
    "queryString": [
    {
    "name": "-drlkxz",
    "value": ""
    }
    ],
    "headersSize": 518
    },
    "response": {
    "status": 403,
    "statusText": "Forbidden",
    "httpVersion": "HTTP/1.1",
    "headers": [
    {
    "name": "Date",
    "value": "Tue, 18 Sep 2018 15:03:45 GMT"
    },
    {
    "name": "Server",
    "value": "Apache/2.2.16 (Debian)"
    },
    {
    "name": "Vary",
    "value": "Accept-Encoding"
    },
    {
    "name": "Content-Encoding",
    "value": "gzip"
    },
    {
    "name": "Content-Length",
    "value": "208"
    },
    {
    "name": "Keep-Alive",
    "value": "timeout=15, max=83"
    },
    {
    "name": "Connection",
    "value": "Keep-Alive"
    },
    {
    "name": "Content-Type",
    "value": "text/html; charset=iso-8859-1"
    }
    ],
    "cookies": [],
    "content": {
    "mimeType": "text/html; charset=iso-8859-1",
    "size": 243,
    "text": "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>403 Forbidden</title>\n</head><body>\n<h1>Forbidden</h1>\n<p>You don't have permission to access /themes/default/assets/fonts/ispconfig.ttf\non this server.</p>\n</body></html>\n"
    },
    "redirectURL": "",
    "headersSize": 264,
    "bodySize": 472
    },
    "cache": {},
    "timings": {
    "blocked": 7,
    "dns": 0,
    "connect": 0,
    "ssl": 0,
    "send": 0,
    "wait": 6,
    "receive": 4
    },
    "time": 17,
    "_securityState": "secure",
    "serverIPAddress": "192.168.0.39",
    "connection": "8080"
    }
    ]
    }
    }

    but the file permissions are ok (compared with an other ISPConfig server)

    -rwxr-x--- 1 ispconfig ispconfig 20335 Aug 28 14:30 glyphicons-halflings-regular.eot
    -rwxr-x--- 1 ispconfig ispconfig 62926 Aug 28 14:30 glyphicons-halflings-regular.svg
    -rwxr-x--- 1 ispconfig ispconfig 41280 Aug 28 14:30 glyphicons-halflings-regular.ttf
    -rwxr-x--- 1 ispconfig ispconfig 23320 Aug 28 14:30 glyphicons-halflings-regular.woff
    -rwxr-x--- 1 ispconfig ispconfig 9752 Aug 28 14:30 ispconfig.eot
    -rwxr-x--- 1 ispconfig ispconfig 37161 Aug 28 14:30 ispconfig.svg
    -rwxr-x--- 1 ispconfig ispconfig 9580 Aug 28 14:30 ispconfig.ttf
    -rwxr-x--- 1 ispconfig ispconfig 9656 Aug 28 14:30 ispconfig.woff

    Where can I look for permission settings font access?

    Thanks
     

Share This Page