Update to 3.1b2 - Error message

Discussion in 'Developers' Forum' started by wpshosting.com, Jul 24, 2016.

  1. wpshosting.com

    wpshosting.com New Member

    I'm testing the new version, but when I run the update I have this strange message at the end of the process:
    Catchable fatal error: Argument 4 to mysqli_connect() must be of type ?string, bool given in tmp/ispconfig3_1_roundcube/install/lib/mysql.lib.php on line 204

    I verified that everything is ok, the system works but I do not yet understand why this error!

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What is ispconfig3_1_roundcube ? We do not provide a roundcube installer.
  3. wpshosting.com

    wpshosting.com New Member

    Hi till,
    I renamed ispconfig install folder!
  4. Jesse Norell

    Jesse Norell Active Member

    what version of "3.1" are you using there? I believe there were some mysqli errors fixed along the way, and I've not seen any for a while; I just updated to git-stable (via ispconfig_update.sh script) right now and don't see that. You may just need to get a newer "3.1"?
  5. wpshosting.com

    wpshosting.com New Member

    It is 3.1b2...
    I run update to 3.1b2 and receive this errot.
  6. Jesse Norell

    Jesse Norell Active Member

Share This Page