update 2.2.18, suexec and php_admin_flag safe_mode (not wanting suphp) are failing

Discussion in 'General' started by Melchior, Dec 27, 2007.

  1. Melchior

    Melchior New Member

    after I switched over to newest version 2.2.18 I got in trouble with

    Any changes didn't get written. So I reverted last written one and got
    this failure:
    Syntax error on line 45 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
    I know that php_admin_flag safe_mode is bugging me, but I didn't found
    a way to prevent this.

    I strongly need suexec for my setup, and till 2.2.14 all works fine. In
    those days I already patched my settings to:
    $go_info["server"]["apache2_php"] = 'addtype';
    is there a way to suppress writing "php_admin_flag safe_mode" to vhost-file?
    If remove "php_admin_flag safe_mode" manually, all is working fine

    big thx for great support given to us here!
    Last edited: Dec 27, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I recommend that you use suphp as it does the same then suexec for php. If you really want to use suexec and not suphp, you will have to change the ISPConfig sources (/root/ispconfig/scripts/lib/config.lib.php).
  3. Melchior

    Melchior New Member

    thx for reply. patching works.

    but, uhmm, did ispconfig kicked-off suexec support at all?

    php access failes now with:
    [Thu Dec 27 18:53:48 2007] [error] [client] (2)No such file or directory: FastCGI: stat() of "/var/www/web18/web/php-fastcgi" failed
    (whatever know why it's looking there)

    and after adding a new webhost, no subdir is being created in /var/www/php-fastcgi/

    I checked changelog between my versions and did not see any annoucement about suexec

    am I wrong?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, we did not change anything in SuEXEC support. But PHP with SuEXEC was never a officially supported option, so it might be that a change in one of the other PHP setup options broke your installation.

    No version of ISPConfig creates subdirs there. ISPConfig has no builtin fastcgi support.
  5. Melchior

    Melchior New Member

    hehe sorry,

    I totally forgot that I once patched ISPConfig to run with suExec-Support.

    after patching again all works fine now :)


Share This Page