unrealircd rpm build errors

Discussion in 'Installation/Configuration' started by Laurelai, Dec 27, 2010.

  1. Laurelai

    Laurelai New Member

    Im trying to update an rpm for unreal ircd originally found from the atomicore repo, the repo uses 3.2.7 and im trying to use the latest which is 3.2.8.1, I edited the spec file to change all instances of 3.2.7 to 3.2.8.1 but when i run rpmbuild -ba unrealircd-art.spec I receive the following error.

    http://pastebin.com/x1zcEyy5

    Here is my spec file

    http://pastebin.com/qh6U7apj

    Could you please point me in the right direction?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you run these commands on the shell?

    Code:
    cd /home/rpmbuild/rpmbuild/BUILD
    rm -rf Unreal3.2.8.1
    /bin/gzip -dc /home/rpmbuild/rpmbuild/SOURCES/Unreal3.2.8.1.tar.gz
    tar -xf -
    What's the output of
    Code:
    ls -la
    afterwards?
     
  3. Laurelai

    Laurelai New Member

    Code:
    [rpmbuild@vps BUILD]$ /bin/gzip -dc /home/rpmbuild/rpmbuild/SOURCES/Unreal3.2.8.1.tar.gz tar -xf -
    /bin/gzip: invalid option -- x
    gzip 1.3.5
    (2002-09-30)
    usage: gzip [-cdfhlLnNrtvV19] [-S suffix] [file ...]
     -c --stdout      write on standard output, keep original files unchanged
     -d --decompress  decompress
     -f --force       force overwrite of output file and compress links
     -h --help        give this help
     -l --list        list compressed file contents
     -L --license     display software license
     -n --no-name     do not save or restore the original name and time stamp
     -N --name        save or restore the original name and time stamp
     -q --quiet       suppress all warnings
     -r --recursive   operate recursively on directories
     -S .suf  --suffix .suf     use suffix .suf on compressed files
     -t --test        test compressed file integrity
     -v --verbose     verbose mode
     -V --version     display version number
     -1 --fast        compress faster
     -9 --best        compress better
        --rsyncable   Make rsync-friendly archive
     file...          files to (de)compress. If none given, use standard input.
    Report bugs to <[email protected]>.
    
     
  4. Laurelai

    Laurelai New Member

    I also tried

    /bin/gzip -dc /home/rpmbuild/rpmbuild/SOURCES/Unreal3.2.8.1.tar.gz
    tar -xf -

    as two separate commands but it made my terminal spit out this ridiculous wall of text that kept going and going :s
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Yes, it must be two separate commands.

    Did you see any errors at the end?

    Can you post the output of
    Code:
    ls -la
    afterwards?
     
  6. Laurelai

    Laurelai New Member

    Code:
    [rpmbuild@vps BUILD]$ ls -la
    total 16
    drwxrwxr-x 2 rpmbuild rpmbuild 4096 Dec 29 03:23 .
    drwxrwxr-x 6 rpmbuild rpmbuild 4096 Dec 27 01:23 ..
    
    as for errors, the whole thing looked like it was spitting out the entire unreal source code into my terminal and this process took about 5-7 minutes

    the last part of it looked like this

    Code:
    ==[ BOOTING YOUR IRCD ]==
    Just type: ./unreal start
    Note that after booting the errors are usually logged to ircd.log,
    so check that file if you have any problems.
    Again, check the FAQ (and docs) if you have any boot problems.
    [rpmbuild@vps BUILD]$ 62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c
    
    I would include the whole thing but the scrollback buffer on my terminal was far exceeded and i dont think a pastebin would do it.
     

Share This Page