Unnecessary Postfix relays mail after server move (IP change)

Discussion in 'Installation/Configuration' started by whimboo, Oct 24, 2011.

  1. whimboo

    whimboo New Member

    Hi,

    Due to an exchange of one of my servers I had to copy the domU with my ispconfig installation to another machine, which is located in another network. That means the domU also needs a new IP. I have changed (I hope) all of the instances of the old IP in the ispconfig db and in local configuration files. So far everything (bind, web, ftp, ssh, ...) works fine except for postfix. When I want to send an email to the copied domU (the old is still active), the mail is received but directly forwarded to the old domU instance. The nameserver entries point to the new IP and hostname, so that cannot be the issue.

    Here an example for the address [email protected] with example.org hosted on vsrv01.xyz.info:

    vsrv01.xyz.info:/var/log/mail.log:
    to=<[email protected]>, orig_to=<[email protected]>, relay=vsrv03.xyz.info[88.198.149.xxx]:25

    Which file/setting I would have to check/change to stop postfix using the old domU as relay? I really can't find any other instance of 'vsrv03' in any of the configuration files on 'vsrv01'.

    Thanks in advance.
    Henrik
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any transports or aliases set? Do you use a relay in your main.cf?
     
  3. whimboo

    whimboo New Member

    Thanks for your reply. I checked all the config files again, and while preparing the main.cfg for this thread I have seen the reference to /etc/mailname and checked it again. Not sure why but a former grep on the /etc/ folder hasn't shown me that file. The old server name was still in there.

    Now everything works fine.
     

Share This Page