UNKNOWN_USER'@'localhost' configuring postfix

Discussion in 'HOWTO-Related Questions' started by punkracy, May 6, 2008.

  1. punkracy

    punkracy New Member

    I've followed "Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10)" tutorial. At the end I'm getting following error in:
    May 4 06:43:13 punkracy postfix/cleanup[22340]: warning: connect to mysql server Access denied for user 'UNKNOWN_USER'@'localhost' (using password: YES)
    of course I can connect to db using mysql client and providing correct password. I think that there's a problem with pam. Postfix doesn't read /etc/pam.d/smtpd (I've tried also /etc/pam.d/smtpd)

    Because of that he cannot authorize user (check if that user exist in db), so he thinks that there is relay (i think that is because of this)

    Do you have any ideas?

    Best regards
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that you have the correct user name and password in the mysql*.cf files.
  3. punkracy

    punkracy New Member

    Yes, they are correct for sure. It seems like it (postfix?) don't even use those (or pam) files and values.
    I'm also getting following errors:
    warning: do not list domain punkracy.com in BOTH mydestination and virtual_mailbox_domains
    warning: 090E8B40EB7: virtual_alias_maps map lookup problem for [email protected]
    451 4.3.0 Error: queue file write error

    May 4 06:31:26 punkracy postfix/smtpd[22303]: sql_select option missing
    May 4 06:31:26 punkracy postfix/smtpd[22303]: auxpropfunc error no mechanism available
    May 4 06:31:26 punkracy postfix/smtpd[22303]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql

    but i'm having select in /etc/postfix/mysql*.cf
    query = SELECT ....
    and in /etc/postfix/sasl/smtpd.conf
    sql_select: select password from users where email = '%u'

    Thanks in advance
  4. falko

    falko Super Moderator ISPConfig Developer

    http://www.howtoforge.com/forums/sh...=listed mydestination virtual_mailbox_domains

    http://www.howtoforge.com/forums/sh...asl_plugin_load failed sasl_auxprop_plug_init

Share This Page