Unknown (maildrop) error

Discussion in 'Installation/Configuration' started by Skprorok, Jul 27, 2009.

  1. Skprorok

    Skprorok New Member

    Hi!

    I am using ISPConfig 3.0.1.1.
    When I create mailbox on my server (for example "aaa@domain.com") and try to send e-mail there from other mailbox, I will not receive it.

    When I look at "Mail-Queue" I have mail there with error:
    (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)

    Can some1 help me please?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Delete the directory of the mailbox on the shell (e.f. /var/vmail/example.com/user ) and then send a email to this mailbox.
     
  3. Skprorok

    Skprorok New Member

    More errors

    I deleted dir and i got more errors

    (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied maildirmake: /var/vmail/reporter.sk/reporter: Permission denied chmod: changing permissions of `/var/vmail/reporter.sk': Operation not permitted sh: /var/vmail/reporter.sk/reporter/ispconfig_mailsize: No such file or directory /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/reporter.sk/reporter/6486.0.servervg.prestavka.sk.)
    reporter@reporter.sk
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    ls -la /var/vmail/reporter.sk

    and

    ls -la /usr/bin/maildrop
     
  5. Skprorok

    Skprorok New Member

    ls -la /var/vmail/reporter.sk :

    drwxr-xr-x 2 root root 4096 2009-07-27 12:17
    drwxr-xr-x 6 vmail vmail 4096 2009-07-27 00:06


    ls -la /usr/bin/maildrop :

    -rwxr-sr-x 1 root mail 170016 2008-05-09 14:38 /usr/bin/maildrop
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please run:

    chown -R vmail:vmail /var/vmail/reporter.sk

    and then try to send a email to the account again.
     
  7. Skprorok

    Skprorok New Member

    Thank you :)
     
  8. jamesloker

    jamesloker New Member

    It's started happening to me

    Hope you can help me too!

    Today our mail server just decided to start doing this for no apparent reason

    In the Webmin postfix module email queue there is the following message under status for every message

    Code:
    temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.
    ls -la /var/vmail/glemsfordschool.local returns the following

    Code:
    root@belle:/var/vmail# ls -la /var/vmail/glemsfordschool.local
    total 12
    drwx------ 3 vmail vmail 4096 2010-02-01 15:44 .
    drwxr-xr-x 5 vmail vmail 4096 2010-02-01 15:57 ..
    drwx------ 5 vmail vmail 4096 2010-02-01 15:44 incoming
    ls -la /usr/bin/maildrop returns the following:

    Code:
    root@belle:/var/vmail# ls -la /usr/bin/maildrop
    -rwxr-xr-x 1 root vmail 179520 2010-01-30 23:02 /usr/bin/maildrop
    And still the emails remain with the same problem. No changes have been made to the system prior to this happening.

    Any ideas please. We are unable to get emails otherwise.

    Thanks in advance

    james
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The permissions in your system are ok, so your issue is not related to the one in this thread. Did you install any Linux updates or did you use the postfix module in webmin before this started to happen? Have you checked if your disk is not full with "df -h"?
     
  10. jamesloker

    jamesloker New Member

    I have had webmin installed with the postfix module since before this happened.
    No updates for at least a couple of weeks and have restarted since then.
    Loads of space
    df -h returns this
    Code:
    root@belle:/var/vmail/glemsfordschool.local# df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda1             224G  5.8G  207G   3% /
    tmpfs                 993M     0  993M   0% /lib/init/rw
    varrun                993M  380K  993M   1% /var/run
    varlock               993M     0  993M   0% /var/lock
    udev                  993M  140K  993M   1% /dev
    tmpfs                 993M     0  993M   0% /dev/shm
    lrm                   993M  2.5M  991M   1% /lib/modules/2.6.28-17-server/volatile
    root@belle:/var/vmail/glemsfordschool.local#
    So lots there.
     
  11. mooseman

    mooseman New Member

    Same problem

    Was there a recent update that messed up vmail / maildrop?
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This question can not be answered that generally and it is not related to ispconfig updates, maildrop is part of your linux distribution or compiled manually and not part of ispconfig. Check the website of your linux distribution if they released a maildrop update since you last updated your system.
     
  13. mooseman

    mooseman New Member

    It's weird I'm getting the same error:

    temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.

    all mail is getting queued in:

    /var/spool/postfix/deferred

    I have to make sure I don't loose the mail while I fix this problem.

    Any idea where I can start looking?


    an authtest returns:

    Authentication succeeded.

    Authenticated: webmaster@domain.com (uid 5000, gid 5000)
    Home Directory: /var/vmail
    Maildir: /var/vmail/domain.com/webmaster
    Quota: 0
    Encrypted Password:[HASH]
    Cleartext Password: (none)
    Options: disableimap=0,disablepop3=0


    Any help would be appreciated...
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    something must have changed your mail config files. The easiest way to restore it is to download the ispconfig 3.0.1.6 tar.gz, unpack it, run the update.php script in the install folder and choose to reconfigure services when the updater asks you.
     
  15. ThomasEriksen

    ThomasEriksen New Member

    Sorry to crash this thread, but I also get the same error.

    Tried to reconfigure services as surgested in #14, but without any luck.

    Unfortunately I still know very little about linux/Ubuntu, so I have no idea of what to do to solve this problem?
     
  16. primal23

    primal23 New Member

    I'm having the same issue on Ubuntu, and I ran the update.php and reconfigured everything and it isnt releasing any of the emails.
     
  17. mooseman

    mooseman New Member

    Hi,

    I just ran through the update.php with reconfigure and no dice...

    How can I tell what updates were installed on ubuntu during the last day or so that might have messed up postfix or maildump?

    --
    Dan
     
  18. mooseman

    mooseman New Member

    Ok, with so many people experiencing the same issue on the same day, there must definitely be an update that fuzzed this all up for us... Does anyone know the exact process on how postfix interacts with imaildump to "dump" email into the user's respective mailbox? If we disect the process we may be able to debug the problem together.

    --
    Dan
     
  19. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I'am not able to answer anything more in this thread as too many poeple crossposted here. Please post the content o the master.cf, but only one of you guys. If you all post here again and cause chaos, I will simply stop here.
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please run these commands to ensure that maildrop is accessible and that it can connet to courier auth daemon:

    chmod 755 /var/run/courier/authdaemon/
    chmod +s /usr/bin/maildrop

    if this wont help, compare the lines for maildrop in master.cf with these lines:

    Code:
    maildrop  unix  -       n       n       -       -       pipe
      flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
     
    Last edited: Feb 1, 2010

Share This Page