Unknown column 'server_php_id' in 'field list'

Discussion in 'General' started by Sjun, Jul 28, 2020.

  1. Sjun

    Sjun New Member

    Hello,

    Yesterday I installed ISPConfig3.1 as per the instructions, although the instructions are for Ubuntu 18.04, where the tutorial linked me to the instructions for 20.04 LTS. (https://www.howtoforge.com/tutorial/ubuntu-lts-minimal-server/) (Page 1 of perfect server)
    obviously, i went that route.

    All seemed to have went well right until i tried to create a new website.
    Upon submitting the form, a message appeared:
    Unknown column 'server_php_id' in 'field list'
    What can I do?
     
  2. nonameboy

    nonameboy New Member

    Attached Files:

  3. Jesse Norell

    Jesse Norell Well-Known Member

    Sounds like it probably needs a bit of updating if it's now resulting in a 20.04 system - @till

    I'd guess the message is due to changes in https://git.ispconfig.org/ispconfig/ispconfig3/-/commit/fc981223a76fe0d268ba42b2728865d8dd91ece8 .. are you on the latest 3.1dev? If not, try updating to that (git-stable) and see if things work - as I understand (but haven't tested), it should work with Ubuntu 20.04. If you are, check that your web_domain table has that server_php_id field and try running the sql updates from upd_dev_collection.sql as shown in that commit.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Nevermind, I should have checked the links first - the perfect server tutorial clearly says, "Before proceeding further you need to have a basic minimal installation of Ubuntu 18.04 as explained in the tutorial." So nothing needs changed there. Probably just a bug in 3.1dev right now.
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The tutorial in the beginning links to https://www.howtoforge.com/tutorial/ubuntu-lts-minimal-server/ for instructions on installing the Ubuntu. But the 18.04 tutorial should link to https://www.howtoforge.com/tutorial/ubuntu-18.04-bionic-beaver-minimal-server/ . This would help prevent the confusion of OP on what OS to install.
    And to @Sjun and @nonameboy : the Perfect Server tutorial you used is for Ubuntu 18.04. You need to install that Ubuntu, not 20.04. ISPConfig published version does not work on Ubuntu 20.04.
     
  6. nonameboy

    nonameboy New Member

    i used 18.04.. then follow instructions and any time have this problem
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Jesse explained it in #3 and #4. Please run this SQL query in the dbispconfig database with phpmyadmin to fix the issue in the dev version:

    Code:
    ALTER TABLE `web_domain` ADD `server_php_id` INT(11) UNSIGNED NOT NULL DEFAULT 0;
     
    nonameboy likes this.
  8. Sjun

    Sjun New Member

    Thank you very much, this indeed solved my issue.
     
    Last edited: Jul 29, 2020
  9. nonameboy

    nonameboy New Member

    thank you till!
     

Share This Page