Unknown column 'server_php_id' in 'field list'

Discussion in 'General' started by Sjun, Jul 28, 2020.

  1. Sjun

    Sjun New Member

    Hello,

    Yesterday I installed ISPConfig3.1 as per the instructions, although the instructions are for Ubuntu 18.04, where the tutorial linked me to the instructions for 20.04 LTS. (https://www.howtoforge.com/tutorial/ubuntu-lts-minimal-server/) (Page 1 of perfect server)
    obviously, i went that route.

    All seemed to have went well right until i tried to create a new website.
    Upon submitting the form, a message appeared:
    Unknown column 'server_php_id' in 'field list'
    What can I do?
     
  2. nonameboy

    nonameboy New Member

    Attached Files:

  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Sounds like it probably needs a bit of updating if it's now resulting in a 20.04 system - @till

    I'd guess the message is due to changes in https://git.ispconfig.org/ispconfig/ispconfig3/-/commit/fc981223a76fe0d268ba42b2728865d8dd91ece8 .. are you on the latest 3.1dev? If not, try updating to that (git-stable) and see if things work - as I understand (but haven't tested), it should work with Ubuntu 20.04. If you are, check that your web_domain table has that server_php_id field and try running the sql updates from upd_dev_collection.sql as shown in that commit.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Nevermind, I should have checked the links first - the perfect server tutorial clearly says, "Before proceeding further you need to have a basic minimal installation of Ubuntu 18.04 as explained in the tutorial." So nothing needs changed there. Probably just a bug in 3.1dev right now.
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The tutorial in the beginning links to https://www.howtoforge.com/tutorial/ubuntu-lts-minimal-server/ for instructions on installing the Ubuntu. But the 18.04 tutorial should link to https://www.howtoforge.com/tutorial/ubuntu-18.04-bionic-beaver-minimal-server/ . This would help prevent the confusion of OP on what OS to install.
    And to @Sjun and @nonameboy : the Perfect Server tutorial you used is for Ubuntu 18.04. You need to install that Ubuntu, not 20.04. ISPConfig published version does not work on Ubuntu 20.04.
     
  6. nonameboy

    nonameboy New Member

    i used 18.04.. then follow instructions and any time have this problem
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Jesse explained it in #3 and #4. Please run this SQL query in the dbispconfig database with phpmyadmin to fix the issue in the dev version:

    Code:
    ALTER TABLE `web_domain` ADD `server_php_id` INT(11) UNSIGNED NOT NULL DEFAULT 0;
     
    nonameboy likes this.
  8. Sjun

    Sjun New Member

    Thank you very much, this indeed solved my issue.
     
    Last edited: Jul 29, 2020
  9. nonameboy

    nonameboy New Member

    thank you till!
     
  10. highlander111

    highlander111 New Member

    Hi, i have the same issue...

    When doing

    ALTER TABLE `web_domain` ADD `server_php_id` INT(11) UNSIGNED NOT NULL DEFAULT 0;


    in the dbispconfig


    i get the ERROR

    #1292 - Falscher date-Wert: '0000-00-00' für Feld 'last_quota_notification' in Zeile 5


    what did i do wrong?



    Thanks for your help in advance

    High

    p.s. i also have ubuntu 18.04.. it occured since an upgrade from 16.04

    p.p.s i messed around in the section -> SYSTEM -> SERVERCONFIGURATION -> WEB -> PHP SETTINGS where i changed manually the paths from (existing) php5 to php7.2 ... can it be i made an error here? thanks again
     
    Last edited: Nov 12, 2020
  11. highlander111

    highlander111 New Member

    concerning paths in -> SYSTEM -> SERVERCONFIGURATION -> WEB -> PHP SETTINGS


    i think i did all correctly, i'm only unsure with the following:

    PHP-FPM Init Script i have: php-fpm7.2

    is this correct for ubuntu 18.4 ?
     
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That is a completely different error than what this discussion is about.
     
  13. highlander111

    highlander111 New Member

    p.s. i played around in phpmyadmin

    i edited the parameters for "last_quota_notification"
    and altered the data type from "date" to ... i tried all with no success (errors in phpmyadmin).. but "BLOB" worked... now i don't have the error in ispconfig and can successfully add new websites to it.. however this is no real workaround... can you tell what the problem here is? .. it always refers to an error in "line 5" ... what is meant by line 5?
    thanks again and keep up pyour great work with ispconfig!
     
  14. highlander111

    highlander111 New Member

    Hi Taleman, thanks for your reply!

    Yes and no.. i had the original error: Unknown column 'server_php_id' in 'field list'
    there was a suggestion to fix it with an sql-statement.. when i applied it, i got the above error .. date value...
     
  15. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That zeile 5 refers to line 5 in the script or sql query that is run. But I do not know what script that is.
     
  16. highlander111

    highlander111 New Member

    ok,thanks again for your reply! it is this line:

    ALTER TABLE `web_domain` ADD `server_php_id` INT(11) UNSIGNED NOT NULL DEFAULT 0;

    for me, it has only 1 line?
     
  17. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It's likely line 5 of the script that is running that, not the sql file itself.

    As to your issue, it sounds like you have incomplete sql updates; you might see if the issue in https://git.ispconfig.org/ispconfig/ispconfig3/-/issues/5870 applies (ie. change row_format to dynamic might allow the sql updates?)
     
  18. highlander111

    highlander111 New Member


    Hi Jesse, thank you very much! I'll look into that!
     

Share This Page