Unknown column 'php_fpm_chroot' in 'field list'

Discussion in 'General' started by Enzo2424, Feb 14, 2019.

  1. Enzo2424

    Enzo2424 New Member

    Hi all !
    I've just installed (second time, had same error on first install, thought I might have missed something) as per tutorial :
    https://www.howtoforge.com/tutorial...sl-pureftpd-bind-postfix-doveot-and-ispconfig

    Everything seems ok until I try to add websites. At first, it seems to work, but when I go into the Redirect or Options tabs while adding a website, the page just shuts with a message up top (just below the icons bar) saying :
    Unknown column 'php_fpm_chroot' in 'field list'.
    The list of websites disappears (refreshing page makes it come back) and all modifications added to website are not taken into account....

    Being that this is second install & I was extra careful to follow step by step, I'm suspecting that this is a bug (in latest release?)

    Nota :
    I doubt this is server related, but this is my first AMD Opteron server (usually using Xeon) : server specs :
    AMD Opteron 4334 (6c/6th) - 32GB DDR3 1600 MHz - HD 2To SATA (x4 SoftRaid)
    If I'm insisting on this, it's because I installed a Xeon server a couple of weeks ago and had 0 problems... so just in case...

    I've been using IspConfig on other servers for awhile now and never had this problem post-install...
    Sounds like there's a glitch in the DB... but where & how do I fix this ?

    Thanks for the great tool & your help on this matter.
    Regards
    Enzo
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a problem in the current ispconfig stable branch, introduced by a commit that sas merged yesterday. I just fixed the issue in the code.

    Run this command in the dbispconfig database with phpmyadmin to add the missing column:

    Code:
    ALTER TABLE `web_domain` ADD COLUMN `php_fpm_chroot` enum('n','y') NOT NULL DEFAULT 'n' AFTER `php_fpm_use_socket`;
     
  3. Enzo2424

    Enzo2424 New Member

    I tried the command, however it doesn't create the column... error persists... maybe a simple mysql command as root via ssh ? Strange that PhpMyAdmin doesn't do the job (kinda like as if the db was locked... but no error messages or anythng.. it just swallows the command & nothing happens..
    I'm not a Mysql console guru, could you guide me on doing this as root in mysql via ssh ?
     
  4. Enzo2424

    Enzo2424 New Member

    Nevermind, I did it via phpmyadmin using add column in table structure... & seems to work... the column appeared in the talbe & ISPConfig is working ok now..
    THANK YOU TILL ! :)
     
    till likes this.

Share This Page