Unattended-upgrades prompts for user/password

Discussion in 'Installation/Configuration' started by Mark.R, Jul 28, 2014.

  1. Mark.R

    Mark.R New Member

    Hello to all of you !

    I'm working with Debian wheezy and KDE 4.8.4 and installed unattended-upgrades by following this tutorial.

    But for each update I get a prompt where I have to select a user with administrative privileges (not the kdesu-prompt) and enter an password.
    After entering user/password the update-job terminates properly with installing all updates.

    Do I have to add a special "update-group" or "update-user" to avoid entering user/password ?

    Thank you for your advice.


    Mark
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Please paste your

     
  3. Mark.R

    Mark.R New Member

    Hi Srijan, thank you for your reply,

    Upps... at this moment the update starts again.
    I checked the caller-PID:
    polkit.subject-pid= 4317 (apper-sentinel)
    polkit.caller-pid= 4344 (packagekitd)

    In .kde/share/config/apper is
     
  4. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please run the command & check the debug report.

    --dry-run will run an unattended upgrades cycle except it will not really install the upgrades, only check and verify that everything is ok.

    --debug will enable verbose mode.

    You can always check the logs for unattended-upgrades at /var/log/unattended-upgrades/unattended-upgrades.log.
     
  5. Mark.R

    Mark.R New Member

    Hi Srijan, thank you for helping me.


    Here are the last three days of unattended-upgrades.log
     
  6. srijan

    srijan New Member HowtoForge Supporter

    Is the user in sudo list, please check it in /etc/sudoers. You can specify the allowed commands with sudo, you don't have to allow unlimited access, e.g.

     
  7. Mark.R

    Mark.R New Member

    No, but the user is member of the group sudo.
    Do you think it is necessary to add the user especially to /etc/sudoers ?
    I previously thought, to be a member of the group sudo works as well.

    Here is my /etc/sudoers:

     
  8. srijan

    srijan New Member HowtoForge Supporter

    Check your sudoers file, my working debiansystem had this configuration

    otherwise manual name addition in file /etc/sudoers will also work
     
  9. Mark.R

    Mark.R New Member

    Thanks for your hint, Srijan.

    The /etc/sudoers files look the same for me.
    I'll add the user to /etc/sudoers and check the updates for the next week.
    After that I'll give you a feedback.

    Have a good time

    Mark
     
  10. Mark.R

    Mark.R New Member

    [SOLVED] Unattended-upgrades prompts for user/password

    Hi Srijan,

    I'm late - sorry, please forgive me....

    Good news - problem solved. It was caused by the local PolicyKit definitions.
    Changing the /etc/sudoers file has brought no effect.

    During searching the www I stumbled over this two sites containing the solution:

    http://www.nux.ro/archive/2011/03/Allow_the_local_user_to_install_and_update_software_without_root_password.html


    http://unix.stackexchange.com/questions/34664/how-to-disable-password-prompting-for-automatic-updates-on-red-hat


    After adding the two .pkla files the system works perfect for me.

    Again, thank you for your help.

    Mark
     

Share This Page