Unable to use ISPConfig in browser

Discussion in 'General' started by manuelh, Jun 20, 2021.

  1. manuelh

    manuelh New Member

    Hello everyone,
    I've used ISPConfig on my old server, but can't get it to run smoothly on my new server. The (current) problem is that I can't access ISPConfig with my browser. All other sites are served by apache, but for ISPConfig I get This site can’t be reached.
    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Ubuntu 20.04.2 LTS
    
    [INFO] uptime:  12:56:24 up 20 days,  1:45,  1 user,  load average: 0.00, 0.07, 0.09
    
    [INFO] memory:
                  total        used        free      shared  buff/cache   available
    Mem:          7.8Gi       1.7Gi       1.3Gi        34Mi       4.8Gi       5.9Gi
    Swap:            0B          0B          0B
    
    [INFO] systemd failed services status:
      UNIT            LOAD   ACTIVE SUB    DESCRIPTION
    ● certbot.service loaded failed failed Certbot
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    
    1 loaded units listed.
    
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.5
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.4.3
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.3
    
    ##### PORT CHECK #####
    
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    
    ##### MAIL SERVER CHECK #####
    
    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.
    
    ##### RUNNING SERVER PROCESSES #####
    
    [INFO] I found the following web server(s):
        Apache 2 (PID 484086)
    [INFO] I found the following mail server(s):
        Postfix (PID 483995)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 484040)
    [INFO] I found the following imap server(s):
        Dovecot (PID 484040)
    [INFO] I found the following ftp server(s):
        PureFTP (PID 484273)
    
    ##### LISTENING PORTS #####
    (only        ()
    Local        (Address)
    [anywhere]:993        (484040/dovecot)
    [anywhere]:995        (484040/dovecot)
    [localhost]:10023        (817/postgrey)
    [localhost]:10024        (484027/amavisd-new)
    [localhost]:10025        (483995/master)
    [localhost]:10026        (484027/amavisd-new)
    [localhost]:10027        (483995/master)
    [localhost]:11211        (586/memcached)
    [anywhere]:110        (484040/dovecot)
    [anywhere]:143        (484040/dovecot)
    [anywhere]:21        (484273/pure-ftpd)
    ***.***.***.***:53        (3940852/systemd-res)
    ***.***.***.***:53        (587/named)
    [localhost]:53        (587/named)
    [anywhere]:22        (657/sshd:)
    [anywhere]:25        (483995/master)
    [localhost]:953        (587/named)
    *:*:*:*::*:993        (484040/dovecot)
    *:*:*:*::*:995        (484040/dovecot)
    *:*:*:*::*:10023        (817/postgrey)
    *:*:*:*::*:10024        (484027/amavisd-new)
    *:*:*:*::*:10026        (484027/amavisd-new)
    *:*:*:*::*:3306        (483311/mysqld)
    [localhost]10        (484040/dovecot)
    [localhost]43        (484040/dovecot)
    *:*:*:*::*:80        (484086/apache2)
    *:*:*:*::*:8081        (484086/apache2)
    *:*:*:*::*:21        (484273/pure-ftpd)
    *:*:*:*::**:*:*:*::*53        (587/named)
    2a03:4000:6:2638:140:53        (587/named)
    *:*:*:*::*:53        (587/named)
    *:*:*:*::*:22        (657/sshd:)
    *:*:*:*::*:25        (483995/master)
    *:*:*:*::*:953        (587/named)
    *:*:*:*::*:443        (484086/apache2)
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    f2b-pure-ftpd  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 21
    f2b-sshd   tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 22
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain f2b-pure-ftpd (1 references)
    target     prot opt source               destination
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    
    Chain f2b-sshd (1 references)
    target     prot opt source               destination
    REJECT     all  --  ***.***.***.***        [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***       [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***       [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***        [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***         [anywhere]/0            reject-with icmp-port-unreachable
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    
    ##### LET'S ENCRYPT #####
    Certbot is installed in /usr/bin/letsencrypt
    This is the OS version I use:
    Code:
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 20.04.2 LTS
    Release:    20.04
    Codename:    focal
    
    PHP version:
    Code:
    PHP 7.4.3 (cli) (built: Oct  6 2020 15:47:56) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.3, Copyright (c), by Zend Technologies
    
    I have tried to use custom configuration templates in the conf-custom, but had no luck with that either.
    Thank you in advance for your help!
     
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    1. Swap file should not be zero.
    2. Default ispconfig.vhost should work immediately upon install unless you change from port 8080 or you did not open port 8080 or you did not point your server hostname FQDN to your server IP and/or ipv6.
    3. Did you successfully obtain LE certs during ISPConfig install / update?
     
  3. manuelh

    manuelh New Member

    Thank you! I didn't pay attention to the swap file, because I used the default settings. I have now created a swap file with 8 GB.
    It did work before when I first installed ISPConfig. Some time after either upgrading the server or upgrading ISPConfig itself it stopped working. In /etc/apache2/sites-available I only have the file ispconfig.conf, no .vhost file.
    Yes, the certification process went through without any problems. For all other sites (while setting them up in ISPConfig) as well.
     
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Check port 8080 whether it is opened and whether that is defined in your ispconfig.conf.
     
  5. manuelh

    manuelh New Member

    netstat -nlp | grep 8080 has no result.
    I just checked the sites-enabled and I can see 000-ispconfig.conf and ispconfig.conf, both linking to ../sites-available/ispconfig.conf. Is this the way it should be o_O?
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No, you can only have one or I believe it will cause an error. Ispconfig uses the 000-* name, the other would be setup manually and should be removed.
    You might try renaming your conf-custom files and run the installer again, answering yes to reconfigure services, and it will put the .vhost file back.
     
  7. manuelh

    manuelh New Member

    I deleted all ispconfig files from sites-available and sites-enabled, checked if there are any conf-custom files and reinstalled/updated ISPConfig with ispconfig_update.sh --force. Now I have ispconfig.conf again in my sites-available, but no .vhost.
     
  8. manuelh

    manuelh New Member

    I see, so that part of the configuration should be fine.

    What surprises me: Where is it specified that ISPConfig runs on port 8080? I actually thought that this happens in ispconfig.conf, but I can't find anything there.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    it's defined in ispconfig.vhost file, which has a symlink 000-ispconfig.vhost in sites-enabled folder.
     
  10. manuelh

    manuelh New Member

    Hi till,
    thank you for your answer, unfortunately there's no ispconfig.vhost file. Only ispconfig.conf.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    This can only happen when you choose not to install ISPConfig UI during installation or when there was no web server installed when you installed iSPConfig or you deleted that file afterwards.

    If this is a fresh installation, then you might just want to uninstall ispconfig using uninstall script and then reinstall it. And take care your server complies with system requirements as described in the perfect server installation guides.
     
    Th0m likes this.
  12. manuelh

    manuelh New Member

    It did work before, so I guess I messed something up while upgrading. The solution for me was to uninstall and re-install again. Now ISPConfig is running again and I can add my sites again.

    Thank you for your help!
     

Share This Page