Unable to set session.save_path when using PHP-FPM

Discussion in 'Installation/Configuration' started by darkangel, Mar 25, 2013.

  1. darkangel

    darkangel New Member

    Hi,

    When using PHP-FPM, it does this:

    ...
    php_admin_value[open_basedir] = none
    php_admin_value[session.save_path] = /var/www/clients/client1/web3/tmp
    php_admin_value[upload_tmp_dir] = /var/www/clients/client1/web3/tmp
    ...

    Because of this, I can't set a different save path in my code. I tried setting it in custom PHP settings, but that doesn't seem to work either.

    I think it's because php_admin_value cannot be overridden, but php_value can, so shouldn't ISPConfig be using php_value? (see here)

    Thanks.
     
  2. darkangel

    darkangel New Member

    Please help.
     
  3. Unfaiir

    Unfaiir New Member

    Did you ever figure this out?

    I am having the same exact issue. I need to change 'session.save_path' but I can't.

    Is there any solution to this?
     
  4. darkangel

    darkangel New Member

    From Till ...

     
  5. Unfaiir

    Unfaiir New Member

    "Almost"

    Thank you very much for responding so quickly with that.

    I changed all of the 'php_admin_value' directives to just 'php_value' in that file but I was still unable to change the 'session.save_path'.

    A little more digging and I found that the 'php_admin_value' directives are ALSO in the vhost files for each site and must be overridden there too.

    The only downside is that unless I modify the vhost template, then the next time I save this site the vhost file will be re-written and I'll have to make these changes again. That is a small price to pay, because without being able to override 'session.save_path' my entire site goes down.

    Feature Request Please Falko?
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post feature requests in the bugtracker.

    http://bugtracker.ispconfig.org

    If it gets enough votes, we will consider to change that.

    Btw. You can override vhost values in the apache directives field of the website.
     
  7. darkangel

    darkangel New Member

    I don't see php_admin_values in the vhost template (vhost.conf.master), at least not for PHP-FPM ... where did you see this?

    PS. If you post a feature request, let me know and I will vote on it.
     
  8. Unfaiir

    Unfaiir New Member

    Thanks Till, I will submit the feature request there.

    This doesn't work for my particular case. I'm using a PHP framework which modifies 'session.save_path' at run time to store sessions in its own session folders (different folders depending on the user type).
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then you can e.g. remove the lines for the session save path from vhost template and php fpm pool template completely if you want to manage it on a per site basis. The templates exist so that a admin can taylor the system for its needs as we can not make all options available trough the interface as this would make the software unusable if we add a few ghundred additional fields with options in the site settings.
     
  10. Unfaiir

    Unfaiir New Member

    Till,

    What I'm suggesting is not to add a lot more fields to the interface.

    In fact, what I'm suggesting would only add a single field to each website, to choose a vhost template to use for that particular website.

    Under the Sites section there would be a new Templates -> VHosts button on the sidebar at the bottom which would allow managing vhost templates.

    I created a feature request for this with more details. Please check it out.

    http://bugtracker.ispconfig.org/index.php?do=details&task_id=2842
     
  11. darkangel

    darkangel New Member

    Are you using Mod-PHP? I'm using PHP-FPM and I didn't have to make any changes to the vhost config.
     

Share This Page