Unable to send with sendmail

Discussion in 'HOWTO-Related Questions' started by Ronald, Jun 23, 2006.

  1. Ronald

    Ronald New Member

    Hi,

    I've just started working with sendmail om my RedHat 7.1 machine and up til now I can only receive e-mail. All attempts to send fail with dsn 4.0.0. "No route to host", eventhough I'm able to connect to the webserver of the domain.

    I hope someone is able to help me with this.

    Here are (some) details:

    Linux lserv02 2.4.2-2 #1 Sun Apr 8 20:41:30 EDT 2001 i686 unknown

    File: /etc/resolv.conf
    search blahblah
    nameserver 192.168.99.138

    File: /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost localhost.localdomain localhost
    192.168.99.10 lserv01.blahblah lserv01
    192.168.99.20 lserv02.blahblah mail.blahblah www.blahblah www.blahblah.nl
    213.75.12.34 planet.nl

    Netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:32768 *:* LISTEN 552/rpc.statd
    tcp 0 0 *:printer *:* LISTEN 775/lpd Waiting
    tcp 0 0 *:mysql *:* LISTEN 914/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 700/smbd
    tcp 0 0 *:pop3 *:* LISTEN 749/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 537/portmap
    tcp 0 0 *:x11 *:* LISTEN 996/X
    tcp 0 0 *:10000 *:* LISTEN 977/perl
    tcp 0 0 *:http *:* LISTEN 838/httpd
    tcp 0 0 *:ftp *:* LISTEN 749/xinetd
    tcp 0 0 *:ssh *:* LISTEN 729/sshd
    tcp 0 0 *:telnet *:* LISTEN 749/xinetd
    tcp 0 0 *:smtp *:* LISTEN 809/sendmail: accep
    tcp 0 0 *:https *:* LISTEN 838/httpd
    tcp 0 0 lserv02.blahblah:32927 80.67.86.63:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32879 a194-109-192-7.de:https ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32921 a194-109-192-9.dep:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32893 a194-109-192-25.de:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32896 a194-109-192-6.dep:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32897 a194-109-192-8.dep:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32899 66.249.93.99:http ESTABLISHED 1730/mozilla-bin
    tcp 0 0 lserv02.blahblah:32912 66.249.93.99:http ESTABLISHED 1730/mozilla-bin

    File: /etc/mail/local-host-names
    # local-host-names - include all aliases for your machine here.
    lserv02.blahblah
    mail.blahblah
    www.blahblah
    wclnt05.blahblah
    blahblah.nl

    File: /etc/mail/relay_domains
    blahblah
    blahblah.nl

    File: /etc/mail/virtusertable
    info@blahblah.nl info@mail.blahblah
    servicedesk@blahblah.nl servicedesk@mail.blahblah
    blahblah@blahblah.nl blahblah@mail.blahblah

    Sendmail messages:

    <xxxx@blahblah.nl (1001/100), delay=00:00:34, xdelay=00:00:15, mailer=esmtp, pri=30051, relay=planet.nl. [213.75.12.30], dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl (1001/100), delay=00:19:22, xdelay=00:00:10, mailer=esmtp, pri=120051, relay=planet.nl. [213.75.12.54], dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (500/100), delay=01:27:07, xdelay=00:00:00, mailer=esmtp, pri=300391, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=01:57:54, xdelay=00:00:00, mailer=esmtp, pri=391243, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=02:07:04, xdelay=00:00:00, mailer=esmtp, pri=480407, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=17:46:19, xdelay=00:00:00, mailer=esmtp, pri=750453, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl (1001/100), delay=21:21:52, xdelay=00:00:21, mailer=esmtp, pri=210051, relay=planet.nl. [213.75.12.46], dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (500/100), delay=22:29:37, xdelay=00:00:00, mailer=esmtp, pri=390391, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=23:00:24, xdelay=00:00:00, mailer=esmtp, pri=481243, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=23:09:34, xdelay=00:00:00, mailer=esmtp, pri=570407, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host
    <xxxx@blahblah.nl> (1001/100), delay=1+14:48:49, xdelay=00:00:00, mailer=esmtp, pri=840453, relay=planet.nl., dsn=4.0.0, stat=Deferred: planet.nl.: No route to host

    Thanks for any advice you may have to offer, Ronald.
     
    Last edited: Jun 24, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Ronald

    Ronald New Member

    Dear Falko,

    the extra info you requested:

    Command: ifconfig

    eth0 Link encap:Ethernet HWaddr 00:02:B3:2B:A7:B5
    inet addr:192.168.99.20 Bcast:192.168.99.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:310 errors:0 dropped:0 overruns:0 frame:0
    TX packets:302 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    Interrupt:9 Base address:0xa400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:86 errors:0 dropped:0 overruns:0 frame:0
    TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0


    Command: route -nee

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface MSS Window irtt
    192.168.99.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 40 0 0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo 40 0 0
    0.0.0.0 192.168.99.138 0.0.0.0 UG 0 0 0 eth0 40 0 0
    Command: ping -c2 google.com

    PING google.com (64.233.167.99) from 192.168.99.20 : 56(84) bytes of data.
    64 bytes from 64.233.167.99: icmp_seq=0 ttl=239 time=104.760 msec
    64 bytes from 64.233.167.99: icmp_seq=1 ttl=239 time=99.963 msec

    --- google.com ping statistics ---
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max/mdev = 99.963/102.361/104.760/2.419 ms

    Command: ping -c2 64.233.187.99

    PING 64.233.187.99 (64.233.187.99) from 192.168.99.20 : 56(84) bytes of data.
    64 bytes from 64.233.187.99: icmp_seq=0 ttl=240 time=100.347 msec
    64 bytes from 64.233.187.99: icmp_seq=1 ttl=240 time=99.972 msec

    --- 64.233.187.99 ping statistics ---
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max/mdev = 99.972/100.159/100.347/0.367 ms

    Hope this helps (you). I do not find anything (obvious) wrong with it.

    Kind Regards,

    Ronald.
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. Ronald

    Ronald New Member

    Dear Falko,

    I have looked at the information at the URL and set my sendmail option accordingly. However, nothing changes. I'm still at a loss.

    Kind Regards,

    Ronald
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Hm... Is it maybe your firewall? What's the output of
    Code:
    iptables -L
    ?
     
  7. Ronald

    Ronald New Member

    No, it's not the firewall (which does not function correctly btw) but it's the router. The router is unable to lookup/resolve MX records. The problem has been solved by adding the nameserver of the ISP to resolv.conf.

    Thanks for your guidance!

    Ronald
     

Share This Page