Unable to send using TLS

Discussion in 'General' started by heftigrat, Jan 16, 2006.

  1. heftigrat

    heftigrat New Member

    Unable to send using TLS <-- strike "TLS", repl w/"any method"

    I am attempting to send an email using TLS and get the following error in "/var/log/mail.log":
    Code:
    Jan 16 12:44:36 bismarck postfix/smtpd[10117]: connect from myjob.corpserver.com[x.x.x.x]
    Jan 16 12:44:37 bismarck postfix/smtpd[10117]: setting up TLS connection from myjob.corpserver.com[x.x.x.x]
    Jan 16 12:44:38 bismarck postfix/smtpd[10117]: TLS connection established from myjob.corpserver.com[x.x.x.x]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jan 16 12:44:39 bismarck postfix/smtpd[10117]: NOQUEUE: reject: RCPT from myjob.corpserver.com[x.x.x.x]: 550 <test@recipient.com>: Recipient address rejected: User unknown in local recipient table; from=<admin@mydom.dom> to=<test@recipient.com> proto=ESMTP helo=<[y.y.y.y]>
    Jan 16 12:44:41 bismarck postfix/smtpd[10117]: lost connection after RCPT from myjob.corpserver.com[x.x.x.x]
    Jan 16 12:44:41 bismarck postfix/smtpd[10117]: disconnect from myjob.corpserver.com[x.x.x.x]
    
     
    Last edited: Jan 16, 2006
  2. till

    till Super Moderator

    Does this error occurs only when you send with TLS?

    Is the email address test@recipient.com listed in /etc/postfix/virtusertable?
     
  3. heftigrat

    heftigrat New Member

    I assumed the answer was "yes", as I was able to send before, but I just checked and the answer as of today is apparently "no".
    No. Why would it need to be? That would mean that I have to add every email address in the world as my clients would undoubtedly want to send to addresses I do not already know. Just to make things clear, "test@recipient.com" is not an account on my server, it is hosted elsewhere. The account on my server is "admin@mydomain.dom" or "mydomain.dom-admin", which is definitely in "/etc/postfix/virtusertable".

    In short I am sending FROM my server using account "admin@mydomain.dom" TO a remote server w/destination address "test@recipient.com".
     
    Last edited: Jan 16, 2006
  4. till

    till Super Moderator

    Ok, i thought test@recipient.com was on your server.

    Have you enabled SMTP authentication in your email client? In outlook it is named somtehing like "SMTP server needs authentication".
     
  5. heftigrat

    heftigrat New Member

    Most certainly. In Mozilla Thunderbird I have the option "Use name and password" checked, and I have filled in the "Username" field.
     
  6. till

    till Super Moderator

    And you are sure that recipient.com is not listed in /etc/postfix/local-host-names ? I wonder why postfix "thinks" its a local address and dont try to resolve it :confused:
     
  7. heftigrat

    heftigrat New Member

    WOW! ::hits head w/2x4:: um, thanks. I forgot that I created recipient.com at one point. It is NOT listed in "/etc/postfix/local-host-named", however, setting up the domain in ISPC must have changed something else, even though I never entered a web/email user/pass. I'm sorry for wasting so much of your time. I am ashamed. :eek:
     
    Last edited: Jan 16, 2006
  8. heftigrat

    heftigrat New Member

    hmmm....an update: I deleted "recipient.com" from ISPC, restarted the SMTP server, even flushed out the saved pw in Thunderbird and restarted T-Bird, still getting the same error. Anything else need to be purged in the config files? Thanks!
     
  9. heftigrat

    heftigrat New Member

    Nevermind, I forgot to empty the ISPC recycle bin. My mistake - again. Thanks anyhow guys! :)
     

Share This Page