Unable to send/recieve emails on fresh installation

Discussion in 'Installation/Configuration' started by hermestrismegistus, Nov 22, 2013.

  1. hermestrismegistus

    hermestrismegistus New Member

    Oke, i guess i need a bit of help.

    Last days i have been bussy to reinstall my vps server. Instead of debian i've decided to use ubuntu for the first time. I've been reinstalling the system 3 times now, following each step of the ubuntu 12.4 tls perfect server guide.

    Everything works fine, but there is no way i`m able to send/recieve emails, not to myself or anyone else.

    When running netstat -ntap

    I don't see postfix in this list, tough postfix doesn't show any errors when restarting.

    I hope someone is able to help me to solve it.

  2. hermestrismegistus

    hermestrismegistus New Member

    Inputs of mail.log

    Last edited: Nov 22, 2013
  3. hermestrismegistus

    hermestrismegistus New Member

    I've also attached a screenshot of squirrelmail that says:

    Message not sent. Server replied:

    Attached Files:

  4. Quaxth

    Quaxth New Member

    Is your server at your Office/Home or in an Data Center?
  5. hermestrismegistus

    hermestrismegistus New Member

    Its in a data center.
  6. Quaxth

    Quaxth New Member

    What's about the SMTP Port? Did your ISP use Port 25 or 587 (SMTPS) or maybe port 465 (SMTPS)? Some Hosters/ISP's using also port 26 instead of 25! Also, did you run an Firewall? If so, have you place exceptions for the required ports in the Firewall Rules?

    Check that all ports on your server you need to have open, are accessible from the Internet. You could use: http://www.mydnstools.info/smtprelay for to check that your Mail Server mail.mydomain.com is working on the internet. There also online Port Check Tools which you could use for that, google for it.
  7. hermestrismegistus

    hermestrismegistus New Member

    Port 25 is open when scanned, but 587 seems closed.

    Where do i configure the port number for smtp?

    Results from relay site you gave me.

  8. Quaxth

    Quaxth New Member

    As you use ISPConfig, use the Perfect Server Guide for Ubuntu for to configure the Mail correctly.

    Maybe you check the SMTP of your ISP. If that is an Open Relay, means no need of Username and password, try that SMTP. In ISPConfig under System -->Server Config and System -->Main Config, you could set the required setting.

    If you'll use the SMTP from your ISP, you just need to key in the SMTP Server name in System -->Server Config under the Mail Tab right of Relayhost.

    That's how I use it on my server.
  9. hermestrismegistus

    hermestrismegistus New Member

    Well, i`m finally getting somewhere..... I've changed the port numbers yesterday, then sended a email from gmail. Then gmail got a reply from postfix on my server that said:

    This made me wonder wether there is something wrong with the account, so i made another one on the same domain. Again i got the same reply inside gmail.

    After this i made an email account on another domain, and guess what. The emails got sended and recieved.

    Again, this made me wonder what was wrong with that other domain name. So i deleted it and recreated it, again same problem....

    So for some reason, i just can't create email adresses for that specific domain name... Anyone any clues what go's wrong here?
  10. Quaxth

    Quaxth New Member

    That means that the SMTP Settings for that domain are wrong. If you use Google's SMTP, you use SMTPS or SSMTP which both is Secure Mail Transport. Google didn't allows Mail Transport unsecured on Port 25.

    Check with your Google Account which port is used, mainly it will be 587, but could be different! Use your Google Credentials for the SMTP/SMTPS/SSMTP in ISPConfig and in your Mail Client and test again.

    Personally I would use an Open Relay SMTP Server and Port 25 which is the most easy to use. Use MyDNSTools for to find one in your Country. Start with the SMTP Server of your own ISP. If you didn't have the SMTP Server Addresses, google for it, special for your country, not abroad.
  11. hermestrismegistus

    hermestrismegistus New Member

    Found the mistake!

    My fault, i had edited /etc/postfix/my.cf in a wrong way, i had changed the destination address from ubuntu.uweigenbedrijfonline to uweigenbedrijfonline.nl

    So ports where my first problem and ports to be the second

    After i restored the my.cnf, everything seem to work :)

    Thanx for your help man!

  12. Quaxth

    Quaxth New Member

    You're welcome!

    Good to see you got things sorted and it's working fine now.

    Good luck.

Share This Page