Unable to send or receive emails

Discussion in 'Installation/Configuration' started by mickburkejnr, Mar 15, 2012.

  1. mickburkejnr

    mickburkejnr New Member

    Hi everyone,

    I've installed ISPConfig 3 on my VPS using the brilliant tutorial here: http://www.howtoforge.com/forums/showthread.php?t=56541

    However, if I go to send an email to an account I've set up on the server I get the following error:

    I've checked my DNS records for that domain, and they are as follows:
    HTML:
    setanta	A		80.xx.xx.xx	
    mail.gravex.co.uk	MX	10	80.xx.xx.xx
    NS		ns1.6sync.net.	
    NS		ns2.6sync.net.	
    NS		ns3.6sync.net.	
    ftp	A		80.xx.xx.xx
    mail	A		80.xx.xx.xx
    dail	A		80.xx.xx.xx
    www	A		80.xx.xx.xx
    .	A		80.xx.xx.xx
    I've also tried to send an email from squirrelmail. I've had no errors come back but I've not had the e-mail come through either.

    I'm not sure what's going on, as I thought adding mail.gravex.co.uk as an MX record would work, but I don't think it has. What do I need to do to make it work?

    Cheers!
     
  2. mickburkejnr

    mickburkejnr New Member

    I deleted all the DNS records held by ISPConfig 3 and transferred them to the VPS providers nameservers. Now when I send email I don't get the DNS error.

    However, I don't get any bounce bank emails and I still can't send emails. I have checked the long and I get the following error:

    Code:
    Mar 16 07:55:23 setanta postfix/smtp[17339]: 64F235F83: to=<[email protected]>, relay=none, delay=0.07, delays=0.07/0.01/0/0, dsn=4.4.1, status=deferred (connect to
    127.0.0.1[127.0.0.1]:10024: Connection refused)
    I have changed the following in the Postfix config file:

    Code:
    inet_interfaces = all
    inet_interfaces = $myhostname
    inet_interfaces = $myhostname, localhost
    inet_interfaces = all
    So that only one of the lines is used at any one time. However, no matter what I use and no matter how many times I restart Postfix I still get that error!

    Any ideas?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Your MX record was totally wrong. First, it must point to an A record, not an IP, and second, it should have read
    gravex.co.uk. (with a dot at the end), so the full MX record should have been something like:

    Code:
    gravex.co.uk.	MX	10	mail
    Please restart amavisd and check that is running afterwards in the output of
    Code:
    netstat -tap
     
: dns, email

Share This Page