Unable to send emails out. Local delivery ok

Discussion in 'Installation/Configuration' started by beeman, Feb 2, 2008.

  1. beeman

    beeman New Member

    Hi
    Due to a HD crash had to reinstall Dapper and ISP Config. Had a problem with gcc4.1.2 and reverted to gcc 3.4 plus modded file as per: http://www.howtoforge.com/forums/showthread.php?t=19222 Thanks very much. But whilst everything seems to be working no emails are arriving 'outside' internal emails are working fine. Incoming emails/spam also fine. To help:- I had to set up server at another location and re set /etc/network/interfaces and /etc/hosts to current host. Secondly the Outlook 'test' message does not work and thirdly I cannot ssh in from other than the same network. I suspect DNS settings - it works on local (192.168.1.250) but not on mailserver.martley.org. Any help would be appreciated from this 'newbie'
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does mailserver.martley.org point to the right server?

    Code:
    mh1:~# dig mailserver.martley.org
    
    ; <<>> DiG 9.3.4 <<>> mailserver.martley.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61045
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mailserver.martley.org.                IN      A
    
    ;; ANSWER SECTION:
    mailserver.martley.org. 86400   IN      A       [B][COLOR="Red"]86.53.36.56[/COLOR][/B]
    
    ;; Query time: 76 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Sun Feb  3 19:16:16 2008
    ;; MSG SIZE  rcvd: 56
    
    mh1:~#
     
  3. beeman

    beeman New Member

    Thanks so much - yes right server IP but found wrong IP in /etc/resolv.conf ie one that had been set up automatically when I loaded Dapper. Afraid I didn't know to look there but a friend did (Thanks Tom)!
    He also cleared the problem in .ssh/known_hosts to get the ssh working.
    Seems to be working OK now.
    Only thing not working is Outlook test message!
     

Share This Page