Unable to send Email

Discussion in 'Installation/Configuration' started by otacon, Sep 3, 2011.

  1. otacon

    otacon New Member

    I use to be able to send email, but now I am having issues.


    Even in squirrel mail it freezes when trying to email things. So this is an internal problem as well.

    My mail logs says:

    I tried to connect to the server with

    [email protected]:~# openssl s_client -connect mail.remcycle.net:25 -starttls smtp
    CONNECTED(00000003)


    And it does not get past connected.

    Libraries Used

    The actual Connection to port 25


    My Listening Processes


    So SMTP is listening

    Definitely Postfix running


    I am not sure what else to try... Could you give me guidance?


    ------------------------------

    I understand I am not able to truly make a connection on port 25, but I don't know what could be causing this.
     
    Last edited: Sep 3, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does smtp without tls work?
     
  3. otacon

    otacon New Member

    I changed my main.cf

    so that TLS looks like : smtpd_use_tls = no

    restarted the computer to make sure everything is fresh and I am still having the same issue.


    Something is blocking port 25 locally. Even the server itself can't telnet into port 25. I am just not sure what it could be.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Port 25 on the server works fine, you prooved that above:

    telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.

    if the port would be blocked, you would have got only a "could not connect to server" message.

    So if port 25 is blocked when you send emails from your mail application, then it has been blocked by e.g. your internet access provider or a firewall but not on the server.

    Many providers block port 25, so you should ask your provider if they block port 25 too. In that case, remove the # in front of the "submission" line in postfix master.cf and use the submission port (587) in your email program to send email.

    And please undo the tls setting change.
     
  5. otacon

    otacon New Member

    I have undone the change.

    telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.


    I thought that did more.... Usually it went to a next prompt so you can do commands, but it gets stuck after connected to localhost.localdomain.

    I try to follow guides to send mail from here but I get

    Connected to localhost.localdomain.
    Escape character is '^]'.
    MAIL FROM:[email protected]
    Connection closed by foreign host.


    I currently am using it on a dedicated server I am paying for so I hope they have not blocked my port 25, but I will check.

    Also using squirrel mail from the server would be local right? That means something locally is not work as the squirrel mail freezes when trying to send anything.


    I am just not sure what it could be. I did mess with squirrel mail, trying to get it to do something a while back, so could it possibly be beneficial to reinstall it?


    I am just guessing at this point.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     

Share This Page