unable to receive email from postfix/ISPconfig with Microcrap Outlook 2007

Discussion in 'Installation/Configuration' started by fireman71, Dec 7, 2007.

  1. fireman71

    fireman71 New Member

    I've loaded ubuntu 7.10 server and ISPconfig following the howto at http://www.howtoforge.com/perfect_server_ubuntu7.10 primarily to play around with it and to self educate.

    Everything seemed to be working fine. I can use squirrelmail to send email out to the internet and can receive email from the internet.

    Problem arose when I tried to setup my fiance an email address. She demands to use Outlook 2007.

    I tried to set Outlook up with a new email account and performed several "test account settings" until outlook reported that it could connect and all setting tests that it performs were passed. The problem is that outlook is not receiving any emails from the postfix server even though it is reporting that it is connecting to it.

    I did some research and surfing and it seems that most people are saying that the "Require logon using SPA" box must be checked in outlook.

    In my case when I check it it refuses to connect at all and outlook reports errors when testing the account settings. So the only way that it will not report an error and appear to work is with the SPA box unchecked.

    When I log in to her account using squirrelmail she has a ton of the outlook test messages sitting there and everything appears just fine, she just isn't getting them downloaded into her outlook program which IS working with 2 other email addesses.

    I don't really see anything in the mail log that I would take as an error and can see entries for it when outlook sends the test message.

    Searching and reading so far hasn't produced any results.

    Can someone point me in the right direction to look for a solution to this problem?

    Thank you,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which messages appear in the mail log file when you try to fetch the emails with outlook. Also make sure that you use the username (web[ID]_user) in outlook as username and not the email address.
  3. fireman71

    fireman71 New Member

    That is sort of what is throwing me. There is no entries at all in the mail log when outlook tries to connect. The only entry that appears is when the test email is sent.

    I am using the web1_username format as well.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then outlook is most likely not connecting at all or not to the correct server. Please try to use the IP address of the server as pop3 server address in outlook.
  5. fireman71

    fireman71 New Member

    Sorry for the delay in replying back to this and many thanks for the assistance so far, but this doesn't change anything with the results.

    I tried the IP address of the server, mail.servernamehere.us and plain old servername.us.

    All of which gave me the same result that Outlook appeared to connect and the test message was sent but no mail is being downloaded from the server and there are no entries in the mail log files showing anything helpful.

    This server is behind a router and pop, imap and smtp ports are all forwarded to the server in question and logging in through squirrelmail shows the messages that outlook sends as a test message.

    This is really stumping me.

    Thank you!
  6. Hans

    Hans Moderator ISPConfig Developer

    Maybe not necessary, because the testmessages do arrive in the mailbox, but to be sure:

    On your local desktop can you establish a connection to your mailserver via telnet?

    To try this do the following:
    Clich on "Run" in the MS Windows start menu.
    execute the following command:

    telnet <server-IP-address> 110


    If the connection has been setup successfully, you can stop this Telnet session by typing "quit".

    You can do the same for port 25

    Last edited: Dec 9, 2007
  7. fireman71

    fireman71 New Member

    I hadn't considered trying this but upon doing so everything seems to be working correctly.

    telnet <server> 110 responds with +OK Hello there and telnet <server> 25 responds ok and the output of ehlo seems to be correct as well.

Share This Page