Unable to open ISPConfig Web

Discussion in 'Installation/Configuration' started by neu2linux, Oct 6, 2005.

  1. Critical

    Critical New Member

    Output:
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    /etc/init.d/iptables status
    Code:
    Firewall is stopped.
    
     
  2. Critical

    Critical New Member

    I have a question... Does it really matter if I give a host or not during the installation, if I set the domain as domain.com would it all still work? or not?
     
  3. falko

    falko Super Moderator

    The installer tries to ping the address you specify. If it doesn't exist, then the ping fails and therefore the installation.
     
  4. Critical

    Critical New Member

    I suppose my question was, would ISPConfig still work properly if I don't supply a host. The installation seems to finish without any problems... It does run, so far, I just havent been able to get the control panel to show... :( I'm very puzzled as to why it won't work for me. Does anyone have any ideas? I'm pretty much stuck.
     
  5. Critical

    Critical New Member

    OK I just got it to work, I'm not sure what happened or how exactly it was fixed... I rebooted the server it for a third time and I guess it fixed it. (hope it stays working) :)
     
  6. Aiken

    Aiken New Member

    On this point I can. I had exactly the same thing after setting up my apache server. If you view the http headers in firefox you'll find the content being server as plain text (mime type text/plain). Firefox is actually rendering the page correctly for this mime type, it's IE that has it wrong.

    Now down to what caused the content to be served up as plain text. When configuring the server I'd commented out all modules that I thought I didn't need. Turns out I got one I shouldn't have - mod_mime and the directives that went with it. I put these back, restarted apache in and it was fine.

    I can't get the the http config file from home, but I'll check on Monday and post an update with the directives you need to resolve this.

    EDIT:
    As promised here are the lines that need to be in the config file to resolve the problem with firefox displaying the page as source

    LoadModule mime_module modules/mod_mime.so

    # TypesConfig describes where the mime.types file (or equivalent) is
    # to be found.
    #
    TypesConfig conf/mime.types

    # DefaultType is the default MIME type the server will use for a document
    # if it cannot otherwise determine one, such as from filename extensions.
    # If your server contains mostly text or HTML documents, "text/plain" is
    # a good value. If most of your content is binary, such as applications
    # or images, you may want to use "application/octet-stream" instead to
    # keep browsers from trying to display binary files as though they are
    # text.
    #
    DefaultType text/plain
     
    Last edited: Apr 3, 2006
  7. dspuser

    dspuser New Member

    @falko

    As you probably have seen I have similar problems.

    Can I write you a private mail with the details ?

    /dspuser
     
  8. falko

    falko Super Moderator

    Why don't you post it here?
     

Share This Page