unable to login to squirel mail. ERROR: Connection dropped by IMAP server.

Discussion in 'Installation/Configuration' started by static442, Apr 22, 2011.

  1. static442

    static442 New Member

    Hello, unable to login to squirell mail. Tried dovecot and courier.

    Here's my mail log.

    Code:
    Apr 21 16:53:59 host imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 16:54:00 host authdaemond: failed to connect to mysql server (server=mysql.example.com, userid=admin): Unknown MySQL server host 'mysql.example.com' (1)
    Apr 21 16:54:00 host imapd: LOGIN FAILED, [email protected], ip=[::ffff:127.0.0.1]
    Apr 21 16:54:00 host imapd: authentication error: Input/output error
    
    Apr 21 18:05:01 host imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:05:01 host imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 21 18:05:01 host pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:05:01 host pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 21 18:05:01 host postfix/smtpd[13892]: warning: SASL: Connect to private/auth failed: No such file or directory
    Apr 21 18:05:01 host postfix/smtpd[13892]: fatal: no SASL authentication mechanisms
    Apr 21 18:05:02 host postfix/master[2781]: warning: process /usr/libexec/postfix/smtpd pid 13892 exit status 1
    Apr 21 18:05:02 host postfix/master[2781]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    I followed Perfect server 5.5 with dovecot and than switched to courier thinking it woudl solve my login issue. Any suggestions greatly appreciated.
     
  2. static442

    static442 New Member

    update

    ok took

    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth

    these lines out of my /etc/postfix/main.cf and seem to have cleaned up the warnings.

    Code:
    Apr 21 18:46:23 host authdaemond: failed to connect to mysql server (server=mysql.example.com, userid=admin): Unknown MySQL server host 'mysql.example.com' (1)
    Apr 21 18:46:23 host imapd: LOGIN FAILED, [email protected], ip=[::ffff:127.0.0.1]
    Apr 21 18:46:23 host imapd: authentication error: Input/output error
    Apr 21 18:46:45 host imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:46:45 host imapd: LOGIN FAILED, user=asdf, ip=[::ffff:127.0.0.1]
    Apr 21 18:46:50 host imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=35, sent=332
    Apr 21 18:47:19 host imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:47:19 host authdaemond: failed to connect to mysql server (server=mysql.example.com, userid=admin): Unknown MySQL server host 'mysql.example.com' (1)
    Apr 21 18:47:19 host imapd: LOGIN FAILED, [email protected], ip=[::ffff:127.0.0.1]
    Apr 21 18:47:19 host imapd: authentication error: Input/output error
    Apr 21 18:50:01 host pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:50:01 host pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 21 18:50:01 host imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 21 18:50:01 host imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 21 18:50:02 host postfix/smtpd[15972]: connect from host.mysite.com[127.0.0.1]
    Apr 21 18:50:02 host postfix/smtpd[15972]: lost connection after CONNECT from host.mysite.com[127.0.0.1]
    Apr 21 18:50:02 host postfix/smtpd[15972]: disconnect from host.mysite.com[127.0.0.1]
    Hope i can get this resolved!
     
  3. static442

    static442 New Member

    update1

    ok switched back to dovecot. Still unable to login to squirell mail but don't get a connection dropped from imap server. Logs look a little better. Mail log shows.

    Code:
    Apr 21 22:09:31 host dovecot: deliver([email protected]): userdb lookup: connect(/var/run/dovecot/auth-master) failed: No such file or directory
    Apr 21 22:09:31 host postfix/pipe[6106]: DC4132803F5: to=<[email protected]>, relay=dovecot, delay=3766, delays=3766/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure)
    Apr 21 22:09:39 host dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    
    it looks like emails are flowing in just have no were to go. So unsure why i am not able to login to email after creation in ispconfig. Reconfigure or reinstall ispconfig?
     
  4. static442

    static442 New Member

    upgrade ispconfig

    ran upgrade on ispconfig and reconfigured config,

    Everything is know working! mail login send and recieve.
     
  5. walkero

    walkero New Member

    @static442

    How did you exactly did the upgrade of ispconfig and you reconfigured it? I also have problem with my emails, and I'm looking for a solution. I can't login from Squirrelmail nor from Evolution. I get the following error at the mail.ingo log

    tail -f /var/log/mail.info

    netstat -tap
    I would really appreciate any help...
     
  6. walkero

    walkero New Member

    I also get this when I try to start dovecot

    /etc/init.d/dovecot start
    I don't know if this makes any sense.

    In my ISPConfig 3.0.3.3 I have configured
    POP3/IMAP Daemon: Courier
    Mailfilter Syntax: Maildrop
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? What's the output of
    Code:
    uname -a
    ?
     
  8. walkero

    walkero New Member

    Thank you for your reply.

    uname -a gives

    Linux ns3.intercube-hosts.com 2.6.32-31-server #61-Ubuntu SMP Fri Apr 8 19:44:42 UTC 2011 x86_64 GNU/Linux
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Ok, now I see that you have Courier installed. So why do you try to start Dovecot when you have Courier?
     

Share This Page