Unable to Login to ISPConfig

Discussion in 'General' started by Stewart81, Jul 29, 2009.

  1. Stewart81

    Stewart81 New Member

    Hi,

    Up until this morning I have never had a problem logging into ISPConfig. Today for whatever reason it won't let me login. I go to the domain and I get the login box. I enter the admin username and passwork, it goes to the login.php file and then redirects me to the login page. I don't receive any type of error about an incorrect username or password. If I enter the wrong information I do receive an error so I know that it's not having a problem with the info in the MySQL DB. Anyone run into this problem before?

    Thanks,

    Stewart
     
  2. till

    till Super Moderator

    Make sure that yor browser accepts cookies and allows header redirects.
     
  3. Stewart81

    Stewart81 New Member

    Hi Till,

    I checked that and it is good. I also verified this with several different browsers and got the same result.

    Thanks,

    Stewart
     
  4. till

    till Super Moderator

    Have you cahnged the mysql root password since you logged in the last time?
     
  5. Stewart81

    Stewart81 New Member

    Hi,

    No, I haven't changed the root pw. In fact it appears to be accessing the database fine because when I enter an incorrect username and password it tells me that the username or password I entered was not found. I would almost suspect a problem with the cookies except for the fact that cookies are enabled and working on every other website.

    Thanks,

    Stewart
     
  6. till

    till Super Moderator

    Have you changed something else like the hostname of the server or the IP?
    Is the harddisk full?
     
  7. Stewart81

    Stewart81 New Member

    Hi Till,

    Nope, the IP and the hostname are still the same and the HD is less than 6% full. The odd thing is it happened right after we had a lightning storm here that knocked my internet out for around 12 hours. I was using it just before and it worked fine. I lost the internet and when the internet came back up I could no longer access it. Just to clarify the ISPConfig is being used on a remote dedicated server.

    Thanks

    Stewart
     
  8. falko

    falko Super Moderator

    Have you tried to clear the browser cache?
     
  9. Stewart81

    Stewart81 New Member

    Hi Falko,

    Yes I cleared the cache.

    Thanks,

    Stewart
     
  10. falko

    falko Super Moderator

    I'd try to restart MySQL or even the whole server. I hope it's no hard drive problem...
     
  11. Stewart81

    Stewart81 New Member

    Hi Falko,

    I tried restarting MySQL and the server with no luck. The websites on the server are working fine and they are all pulling from mysql but I just can't login to ISPConfig.

    Thansk,

    Stewart
     
  12. falko

    falko Super Moderator

    Make a backup of your current ISPConfig installation (back up /root/ispconfig and /home/admispconfig and also the ISPConfig database) and then install the latest ISPConfig version (2.2.32) again. The installer will perform an update - hopefully this will repair your installation.
     

Share This Page