unable to login root in GUI Mode in Suse10

Discussion in 'HOWTO-Related Questions' started by saialkesh, Jan 14, 2006.

  1. saialkesh

    saialkesh New Member

    Hi
    I have managed to install Suse10 on my pc. The installation was fine and immediately after the installation i was able to login in KDE as root and worked on the GUI desktop.
    After having shutdown and restarted the machine, now am unable to login as root in GUI. i can login as other user but not as root. TTY allows me to login as root.

    I need to login as root in GUI.

    Any suggestions whats to be done.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can try to login as root in TTY and the run the command "startx".

    But one question, why do you need root login in KDE?
     
  3. saialkesh

    saialkesh New Member

    Thanks Till. Will try with startx.

    I want to know what to do if root wants to log in in KDE. It did allow me immediately after the installation, but stopped on restart.

    For knowledge sake, need to know what to do in a scenario like this.

    [Till] Sorry, edited your post instead of mine. Redone the changes :)
     
    Last edited by a moderator: Jan 15, 2006
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Edit /etc/opt/kde3/share/config/kdm/kdmrc, find the line with AllowRootLogin
    and set it to true and restart kdm with "rcxdm restart".
     
  5. saialkesh

    saialkesh New Member

    checked the file and it does say allowrootlogin=true. But strangely i still cannot login.

    Strange !!!

    I did not have this problem in 9.3 Is this something related to Ver 10.0.

    I agree its not a good security practice to let root login, but whats making me curious is what is it thats blocking it ?
     
  6. jchajecki

    jchajecki New Member

    I'm not sure its just a version 10 issue. I'm on 9.3 and I recently started having a similar problem. I start up the machine and I get the GUI login. I log in a root and get what looks like a command window. If I type startkde the desktop then starts up. The copmmand window has the title 'Failsafe'. This only happens loggining in as root. Like yourself, I can log in as another user and KDE starts automatocally, but not for root. I have also checked my kdmrc and AllowRootLogin is set to 'true'. I'm still digging around but I'm equally baffled.
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe this is some kind of security measure on SuSE? :confused:
     
  8. jchajecki

    jchajecki New Member

    Some distros do indeed disable this be default, and arguably one shouldn't do this, but SuSE hasn't up to now. Mine worked fine until a couple of days ago. I can do as suggested above (have changed to runlevel 3 and log into the text screen then type startx) and it works fine. I will probably stick to this now as it is safer.
     
  9. jchajecki

    jchajecki New Member

  10. jchajecki

    jchajecki New Member

    Just to point out that the article in the link above seems to have been edited and no longer mentions that SuSE released an update to apply this. As`a result, anyone who has autoupdate enabled and configured may find that all of a sudden their root login to GUI starts a restriced xterm rather than the KDE desktop.
     
  11. MsFree

    MsFree New Member

    I have same issue in SUSE10. After many times loged in as root suddenly lost that option. Of course I did log in trough console shell and startx gives me KDE normally. However when wish to close KDE session many strange messages came back to console shell and finally lost posibility to type in anything into console. One of last messages was that x server is killed.

    Attempt to start new session Ctr+Alt+F2 and login again in order to poweroff machine how I could kill previous unmanagable console shell.
    Also could power off trough remote terminal connection what is basically the same.
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  13. MsFree

    MsFree New Member

    I can understand reasons why KDE desktop is disabled for root, even this is not exactly true. It is still possible to start KDE from console "startx" . This has erratical behavior when wish to close KDE session resulting loosing one console in "nowhere" state. (See my previous post).
    I believe that try to lock root KDE login has no much sense. One who working in linux, should be aware of danger. But it is much easier use yast and make other settings and switching to console window to execute some comands, then work from console all the time. E.G. editing some scripts in different cfg files is more easily using Kwrite then VI in most cases. Also when doing something often we need internet browser and information like this to search for. I am happy when can copy and paste "sausagelong" comand from browser to console shell comand line.
     

Share This Page