Unable to install vzkernel using yum

Discussion in 'Kernel Questions' started by heavylinuxing, Jan 27, 2013.

  1. heavylinuxing

    heavylinuxing New Member

    I am trying to install OpenVz kernel(rhel6) on Fedora 17.Things worked fine for some time until i issued the 'yum install vzkernel' command.There are two errors that i get at the end.
    1.error: systemd conflicts with vzkernel-2.6.32-042stab072.10.i686
    2.error: package:vzkernel-2.6.32-042.stab072.10.i686(openvz-kernel-rhel6)
    needed /sbin/mkinitrd
    Please help.:confused:
  2. falko

    falko Super Moderator ISPConfig Developer

    The OpenVZ kernel is too old. Fedora is using a 3.x kernel already (3.2 or 3.5, I think).
  3. heavylinuxing

    heavylinuxing New Member

    But this was the latest one and a stable one too as per the openvz.org website.And Fedora 17 uses RHEL 6 based kernel which are the recent ones.:confused:
    Does that mean i can't install OpenVZ:(
    I want it desperately for my project.
  4. heavylinuxing

    heavylinuxing New Member

    But the kernel i installed(rhel 6 based) was the latest and stable one as per the OpenVz website.:confused:
    I am new to fedora,so does that /sbin/mknitrd have anything to do with the problem? please bear me.

Share This Page