Unable to install phpbb3

Discussion in 'General' started by Indieben, Feb 5, 2018.

  1. Indieben

    Indieben New Member

    Hi there,

    I am having significant difficulties installing phpbb3.
    I am using the c8databaseuser and c8databasename along with "localhost" (I have tried 127.0.0.1) and I have ensured the database name is short enough (less than 14 (or is it) 16 characters. The installer script will not connect to the database - access denied using password yes. I am not sure where to go to see whether any issues have been logged. I've also got 18 jobs outstanding - it seems that ISPConfig is not putting through my changes on the system. I have restarted the system but the stuck jobs do not process. I have waited a couple of hours. I have also attempted to update ispconfig with apt-get update and apt-get upgrade but the server is not managing to get a connection with security.debian.org (I believe is the address - it has updated with these settings in the past).

    I'm wondering if I have set the DNS ttl a bit to high and whether this is putting a lot of pressure on my server or whether this is a really basis issue whereby I am doing something wrong with installing phpbb. I have also ensured that passwords have no special characters for the db username. Any help would be gratefully received.

    Thanks and Kind Regards,

    Indieben.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Indieben

    Indieben New Member

    Thaks Till, I've done that and put a # in front of the cronjob and saved that. I then ran the command and I get "Warning - there is already an instance of server.php running with pid 1174 and that appears to be it :)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check with ps command if there s still a process with ID 1174, if it does not finish within a few minutes, then try to kill it with kill command.
     
  5. Indieben

    Indieben New Member

    Thanks for this, I ran the command in the instructions, it said that the same PID was still running. When I ran the kill command, the server responded that the PID was not running. I ran the original command, it ran for a few minutes and then seemed to stop of it's own accord, I'm not sure if that is intended. Nothing particular of note, the server seemed to be updating at the time, the only things I saw of interest were:

    restarting httpd
    raised by function server update
    network configuration disabled in server settings.

    The 18 long job queue seems to have disappeared though now even though it stayed there for 10 hours overnight! I think the commands run have something to do with the job queue clearing...

    Thanks again Till :)
     

Share This Page