unable to install on CentOS 5.5

Discussion in 'Installation/Configuration' started by hatted, Oct 25, 2010.

  1. hatted

    hatted New Member

    I used old ISPconfig long ago. now I want to install new version on my new server but no help. I tried to install CentOS 5.5 32/64bit with ISPconfig 2.2.37 on VirtualBox 3.2.10.

    install CentOS, works fine and fast
    update and install components, works fine and fast
    install ISPconfig needs an hour, and then it ask for MySQL info. I put in all the information, and it display OK, but then it shows mysql error
    1045 access denied for user '[email protected]' using password yes,

    but I am pretty sure I have the right password coz I tried 5 times. then it shows
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    ERROR 1146 (42S02) at line 1: Table 'db_ispconfig.sys_user' doesn't exist.

    if i go to admin panel:81 it shows the page but can not login. If I restart, Linux crush.

    I tried ISPConfig2.2.35 and got the same problem. Is it a problem with CentOS5.5? Please help


  2. mini14

    mini14 New Member

    I can only say that 5.5 works fine with ISPConfig2

    Does Vitualbox=virtual server? I'm not familiar with it--if so, I can't speak to your particular issues as my 5.5/ISPC2 installation is running solo on the server.
  3. hatted

    hatted New Member

    so you installed with CentOS5.5 32bit/64bit?
  4. mini14

    mini14 New Member

    Yes. I just built a new webserver about two weeks ago to replace an aging one in need of an upgrade ;)

    This one is CentOS 5.5 32 bit and ISPConfig2 on a Gigabyte MB with Intel processor with 4 gigs of ram and and it's rock stable.

    Hope this helps...
  5. hatted

    hatted New Member

    which ISPC2 version do you use?
  6. hatted

    hatted New Member

    did you move all the user from old ISPC2 to new ISPC2? or just recreated all domains and users?

    I am now installing the server on a Lenovo R120 server. hope it works.
  7. hatted

    hatted New Member

    no help. tried all day on a physical server but got the same error. will try one more time with CentOS 5.4 and ISPC2.2.35, which was work on my another server.
  8. mini14

    mini14 New Member

    Good Morning from America,

    The server was not a clone.. the old server was a cpanel box so there was no direct transfer of accounts.. New accounts were setup for each user and files were then uploaded by the user (or in some cases by me)

    I used the latest ISPC2 version as of 20 days ago.
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you log into MySQL on the shell?
    mysql -u root -p
  10. hatted

    hatted New Member

    Finally I finished setting it up. I changed a few things and it is done. I think the key one is I should not copy the command and paste in the SSH. I think if I copy the command from the installation webpage, it also copied a hidden character in mysql password. so it always said my password incorrect. I hope everyone if you have the same experience next time, do not copy it. TYPE THE PASSWORD.

    thanks mini14, you have given me the confidence the installation is correct.
  11. mini14

    mini14 New Member

    Good deal!

    Glad to hear you got it sorted out!


Share This Page