Unable to install ispconfig 3.1 under php7.1

Discussion in 'Installation/Configuration' started by servidoresadmin.com, Apr 1, 2017.

  1. Hello,
    trying to install ispconfig 3.1 under php7.1 we get:

    Configuring Jailkit
    Configuring Ubuntu Firewall
    Configuring Database
    Updating ISPConfig

    Reconfigure Crontab? (yes,no) [yes]:

    Updating Crontab
    Restarting services ...
    Failed to reload php5-fpm.service: Unit php5-fpm.service failed to load: No such file or directory.
    We try with beta 3.1 but it's same issue. It seems it need a php5 to install.
    Any trick to solve it?


    Administración de servidores
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Read the perfect server guides, they show you which exact PHP version is required on which OS for ISPConfig. None of the tutorials tells you to install PHP 7.1 because there is no ISPConfig version that supports PHP 7.1 yet, ISPConfig requires always the PHP version that is shipped with the OS, so never install any third party php binaries. Just follow the installation tutorials to get a working installation. PHP 7.1 is supported by ISPConfig as additional PHP version, but not as main PHP version.

Share This Page