Unable To Install Centos Guest On Xen 3 Following Guide

Discussion in 'HOWTO-Related Questions' started by mitch.sanders, May 9, 2010.

  1. mitch.sanders

    mitch.sanders New Member

    Hi There,

    I followed this howto and the reason I signed up to your site is to work out why this is happening.

    I have followed hundreds (spending around 8 hours yesterday trying to resolve this) of howtos.

    This one I followed - http://www.howtoforge.com/centos_5.0_xen gets me the furthest. I get through the text based centos install prompts and then start to install centos and when the installer wants to spin up the disk and get it ready to format it gives me the error:

    "Input/output error during read on /dev/xvda" which from what I learnt means that the disk which centos is trying to install onto cannot be found/used/read/written.

    I tried used "dd" to create a disk filled with zeros and that didnt work, tried formatting the drives (drive.img file) as ext3 and that didnt work cant for the life of me work out why and googling my ass off doesnt get me an answer either.

    If you could shed some light, that would be wonderful!

  2. falko

    falko Super Moderator ISPConfig Developer

  3. mitch.sanders

    mitch.sanders New Member

    Hi Falko,

    Yes I followed that guide and found that using virt-install was unsucessful due to the centos installer (on the guest) being unable to detect /dev/xvda.

    So I then proceeded to create a custom config following: http://wiki.centos.org/HowTos/Xen/InstallingCentOSDomU

    I am using centos 5.4 on the host and centos 5.4 installer on the guest.

    I have then tried to boot using /dev/sda using the following xen config and ks-minimal.cfg config.

    kernel = "/var/www/html/centos54/os/images/xen/vmlinuz"
    ramdisk = "/var/www/html/centos54/os/images/xen/initrd.img"
    name = "www2-test"
    extra = "text ks="
    memory = 2048
    disk = [ "tap:aio:/vms/www2/disk01-test.img,sda,w" ]
    vif = [ "mac=00:16:36:4f:3b:3d,bridge=xenbr1,script=vif-bridge" ]
    vcpus = 8
    #bootloader = "/usr/bin/pygrub"
    on_reboot = "destroy"
    on_crash = "destroy"
    contents of http://IP-Of-Webserver/minimal-ks.cfg

    url --url http://IP-Of-Webserver/centos54/os/
    CentOS-5.4-x86_64-bin-DVD.iso is mounted to /var/www/html/centos54/os and is publicly accessible.

    The kernal and ramdisk are used directly from the mounted ISO.

    Using /dev/sda and following the prompts gets the installer to:

    +------------+ No Drives Found +-------------+                 
    |                                                               |                 
    | An error has occurred - no valid devices     |                 
    | were found on which to create new file       |                 
    | systems. Please check your hardware for    |                 
    | the cause of this problem.
    Where-as /dev/xvda brings back a similar error of:

    Input/output error during read on /dev/xvda
    I have spent close to 16 hours googling, trying new things and running around after guide after guide. If you could shead some light that would be amazing!
  4. mitch.sanders

    mitch.sanders New Member

    2.6.18-164.15.1.el5xen is the kernel on the host.
  5. mitch.sanders

    mitch.sanders New Member

    I wrote a long post with heaps of detail that said it needed to be moderated as well as the above post. Not sure where it went (was probably cause it had links in it.)
  6. falko

    falko Super Moderator ISPConfig Developer

    That was our spamfilter. I'm sorry about that - I've just approved your post.

    disk = [ "tap:aio:/vms/www2/disk01-test.img,[COLOR="Red"]xvda[/COLOR],w" ]
    doesn't work?

Share This Page