Unable to have short tags working

Discussion in 'HOWTO-Related Questions' started by Camomille, Feb 26, 2012.

  1. Camomille

    Camomille New Member HowtoForge Supporter

    Hello,

    I have reinstalled my server using "' The Perfect Server Fedora 15_86_64

    Php pages (or inclusion in html) only open if they have a " <?php " at the beginning.
    I am obliged to manually modify all pages since I cannot get it working after edition of /etc/php.ini.

    Here are the first lines of my php.ini :

    I can give you more lines if you want ;) ;)

    I have so many pages to modify! I'll feel more relax and secure if short tags are effectively acceped.
    What am I doing wrong or how can I sort this ?
    I am using Php 5.3.6 on a Fedora 15 64bits.

    Great thanks for your help.

    Camomille
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you restart Apache after your changes?

    If so, please also check your .htaccess files and vhost configurations - they might contain PHP settings as well.
     
  3. Camomille

    Camomille New Member HowtoForge Supporter

    Thanks for your answer and sorry for the late reply !

    1. Sure I restarted Apache after the changes. I also tested by stopping httpd before making any change but this did not help !

    2.I have not found any .htaccess file.

    3.Nothing either in vhost configuration files !!

    I tought I could adapt my scripts but this is not sufficient.
    I had a working Freeradius server and I tryied to install phpmyprepaid yesterday. I mostly got error messages and my freeradius server only send REJECTS with same db as before now !!!
    I saw most of phpmyprepaid files need to have short_tags enabled and I'm afraid it made some faulty changes in my Freeradius files !??? !

    Great thanks for any help or tip.

    Camomille
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you specify any custom php.ini settings in the websites in ispconfig? If yes, then a custim php.ini file is used for that site instaed of the global one.

    You can see in the phpinfo() command which php.ini file is used for a specific website.
     
  5. Camomille

    Camomille New Member HowtoForge Supporter

    Hello,

    I didn't install Ispconfig.

    the usual " /etc/php.ini " file is used and phpinfo shows :
    Code:
    short_open_tag	On	On 
    btw. Freeradius is now back to normal. No explanation ;)

    Great thanks for your reply
     

Share This Page