Unable to get SMTP working

Discussion in 'Installation/Configuration' started by Henkeh, Jan 15, 2010.

  1. Henkeh

    Henkeh New Member

    I get this error when trying to send mails:

    Code:
    Jan 15 20:14:33 C569S02 postfix/smtpd[26645]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
    Jan 15 20:14:34 C569S02 postfix/master[20645]: warning: process /usr/lib/postfix/smtpd pid 26645 exit status 1
    Jan 15 20:14:34 C569S02 postfix/master[20645]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jan 15 20:14:39 C569S02 postfix/smtpd[26614]: connect from localhost.localdomain[127.0.0.1]
    Jan 15 20:14:39 C569S02 postfix/trivial-rewrite[26647]: warning: do not list domain *hiddendomain* in BOTH mydestination and virtual_mailbox_domains
    Jan 15 20:14:39 C569S02 postfix/smtpd[26614]: 4B959EBC21D: client=localhost.localdomain[127.0.0.1]
    Jan 15 20:14:39 C569S02 postfix/cleanup[26650]: 4B959EBC21D: message-id=<7ae9064fd949cc06042a9e27ab5630f5.squirrel@*hidden IP*>
    Jan 15 20:14:39 C569S02 postfix/qmgr[20652]: 4B959EBC21D: from=<newsletter@*hiddendomain*>, size=743, nrcpt=1 (queue active)
    Jan 15 20:14:39 C569S02 postfix/smtpd[26614]: disconnect from localhost.localdomain[127.0.0.1]
    
    I have no idea how to solve it, would be deeply thankful if you could provide some clues on how to fix this. Thanks.
     
  2. till

    till Super Moderator

    Edit postfix main.cf and change the domain in mydestination so that it is not identical with a domain that you want to use to receive email. If the domain is e.g. yourdomain.com, change it e.g. to mail.yourdomain.com

    Then change the line smtpd_recipient_restrictions so that it looks like this:

    Code:
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    and then restart postfix.
     
  3. Henkeh

    Henkeh New Member

    Still nothing.

    Code:
    Jan 18 14:39:35 C569S02 postfix/smtpd[30246]: connect from localhost.localdomain[127.0.0.1]
    Jan 18 14:39:35 C569S02 postfix/smtpd[30246]: BF0E5EBC1FA: client=localhost.localdomain[127.0.0.1]
    Jan 18 14:39:35 C569S02 postfix/cleanup[30253]: BF0E5EBC1FA: message-id=<15eb0fdffddad6ae658e271e8cd852db.squirrel@**hiddenip**>
    Jan 18 14:39:35 C569S02 postfix/qmgr[30240]: BF0E5EBC1FA: from=<newsletter@**hiddendomain**>, size=735, nrcpt=1 (queue active)
    Jan 18 14:39:35 C569S02 postfix/smtpd[30246]: disconnect from localhost.localdomain[127.0.0.1]
    Jan 18 14:39:35 C569S02 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jan 18 14:39:35 C569S02 imapd: LOGIN, user=newsletter@**hiddendomain**, ip=[::ffff:127.0.0.1], port=[39878], protocol=IMAP
    Jan 18 14:39:35 C569S02 imapd: LOGOUT, user=newsletter@**hiddendomain**, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=629, sent=204, time=0
    Jan 18 14:39:36 C569S02 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jan 18 14:39:36 C569S02 imapd: LOGIN, user=newsletter@**hiddendomain**, ip=[::ffff:127.0.0.1], port=[39880], protocol=IMAP
    Jan 18 14:39:36 C569S02 imapd: LOGOUT, user=newsletter@**hiddendomain**, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=119, sent=900, time=0
    Jan 18 14:39:36 C569S02 amavis[30053]: (30053-01) (!)rw_loop: leaving rw loop, no progress
    Jan 18 14:39:36 C569S02 amavis[30053]: (30053-01) (!)FWD via SMTP: <root@**hiddendomain**> -> <root@**hiddendomain**>, 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting:  at (eval 84) line 555, <GEN30> line 322.): id=29242-06
    Jan 18 14:39:36 C569S02 amavis[30053]: (30053-01) Blocked MTA-BLOCKED, <root@**hiddendomain**> -> <root@**hiddendomain**>, Message-ID: <20100118052616.28FB2EBC1F8@**hiddendomain**>, mail_id: yJGmmX2Lt+2R, Hits: 0.01, size: 644, 30171 ms
    Jan 18 14:39:36 C569S02 postfix/smtp[30228]: 28FB2EBC1F8: to=<root@**hiddendomain**>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=29601, delays=29571/0.02/0.01/30, d$
    Jan 18 14:39:36 C569S02 amavis[29242]: (29242-06) (!)rw_loop: leaving rw loop, no progress
    Jan 18 14:39:36 C569S02 amavis[29242]: (29242-06) (!)FWD via SMTP: <root@**hiddendomain**> -> <root@**hiddendomain**>, 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting:  at (eval 84) line 555.): id=30053-01
    Jan 18 14:39:36 C569S02 amavis[29242]: (29242-06) Blocked MTA-BLOCKED, <root@**hiddendomain**> -> <root@**hiddendomain**>, Message-ID: <20100118052616.3096EEBC1F5@**hiddendomain**>, mail_id: dLWBGRUV8K7k, Hits: 0.01, size: 2484, 30121 ms
    Jan 18 14:39:36 C569S02 postfix/smtp[30227]: 3096EEBC1F5: to=<root@**hiddendomain**>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=29601, delays=29571/0.01/0/30, dsn=$
    Jan 18 14:39:41 C569S02 amavis[30053]: (30053-01) (!)rw_loop: leaving rw loop, no progress
    Jan 18 14:39:41 C569S02 amavis[29242]: (29242-06) (!)rw_loop: leaving rw loop, no progress
    
    I have no idea whats happening. :(
     

Share This Page