unable to get ftp server working

Discussion in 'Server Operation' started by dnickelson, Jan 7, 2006.

  1. dnickelson

    dnickelson New Member

    I was following the directions here: http://www.howtoforge.com/pureftpd_mysql_virtual_hosting in order to set up an ftp server. I am doing this on a brand new install of Ubuntu 5.10. It is literally one of the only installations done on the machine (other than SQLAdminstrator and PureAdmin from the 'Add Application' lists). I believe i'd followed instructions fairly well, other than the configuration prompts not coming up after the 2 initial install processes

    (
    Enable suExec? <-- Yes
    Configuring mysql-server (Install Hints) <-- OK
    Which web server would you like to reconfigure automatically? <-- apache, apache2
    Do you want me to restart apache now? <-- Yes

    Run pure-ftpd from inetd or as a standalone server? <-- standalone
    Do you want pure-ftpwho to be installed setuid root? <-- No
    ) - none of these prompts came up...

    Other than that, i've gone through all of the steps and can't find anything wrong. I'm very new to linux, but pretty familiar with sql and passingly familiar with ftp servers, (i'm running mySQL and Cerberus FTP server on a windows machine on the same network, though not using mySQL for user maintenance in this way) and it just appears that the ftp server is not being found. I'm able to vnc into the ubuntu machine from one of my other computers, but just get 'Can't establish connection --> 192.168.1.191:21 @ Sat Jan 07 01:03:41 2006 (0-5)' when attempting to ftp from the same computer. The part I'm not getting is where to configure the ftp service at, as in what port it's listening on, stuff like that. All the configuration seems to center around the sql portion and users.

    As i'd mentioned, i'd installed PureAdmin before i'd started this. perhaps that is part of the problem, but that program does not recognize any ftp server or configuration, and i don't find anything in services or install programs associated with ftp. (On a side note, this computer dual boots to windows xp where i'm also running a cerberus ftp server and i can connect to that just fine using the same test computer and ip address.)

    Any suggestions on where to start?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I wrote the tutorial using Debian - you're using Ubuntu, maybe that's causing your problems.

    FTP is always listening on port 21.

    Please post the output of
    Code:
    netstat -tap
    here.
     
  3. dnickelson

    dnickelson New Member

    (Not all processes could be identified, non-owned process info
    will not be shown, you would have to be root to see it all.)
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdom:1025 *:* LISTEN -
    tcp 0 0 localhost.localdom:1026 *:* LISTEN -
    tcp 0 0 localhost.localdo:mysql *:* LISTEN -
    tcp 0 0 *:5900 *:* LISTEN 7 178/vino-server
    tcp 0 0 localhost.localdoma:ipp *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 0 0 localhost.localdoma:ipp localhost.localdom:2515 ESTABLISHED-
    tcp 0 328 192.168.1.115:5900 192.168.1.113:2771 ESTABLISHED7 178/vino-server
    tcp 0 0 localhost.localdom:2515 localhost.localdoma:ipp ESTABLISHED7 205/gnome-cups-ico
    tcp 0 0 localhost.localdom:1025 localhost.localdom:4058 ESTABLISHED-
    tcp 0 0 localhost.localdom:4058 localhost.localdom:1025 ESTABLISHED-
    tcp6 0 0 *:www *:* LISTEN -


    I have another ftp server running on my network, so i was going to have this one pointing to another port (at least until i get this one running), but i can just change the other one for now too. doesn't look like ftp is running at all from the info above however.

    would have just uninstalled everything and started over with just pureftp if this was a windows install, but not even sure how to do that... (I don't think we're in kansas anymore, toto...)

    Thanks for the reply so far,
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    No, FTP is not running. What customizations did you do to Pure-FTPD?
     

Share This Page