Unable to generate a CSR using the control panel

Discussion in 'Installation/Configuration' started by sipherdee, Jun 11, 2013.

  1. sipherdee

    sipherdee New Member HowtoForge Supporter

    "To create a self-signed certificate, please fill out the fields State, Locality, Organisation, Organisation Unit, Country, and SSL Domain, and then select Create Certificate from the SSL Action drop-down menu, and click on Save. Leave the fields SSL Key, SSL Request, SSL Certificate, and SSL Bundle empty - the fields SSL Key, SSL Request and SSL Certificate will be filled out by the system."

    I am following those instructions and nothing is happening. "SSL Key", "SSL Request" and "SSL Certificate" are not filled out as they should. What do you suggest? In fact, I want to create a certificate signing request to get one from a certificate authority. I tried restarting Apache, looked at the 'ssl' directory for my sites and nothing is getting created. Also, I did not find anything in the logs. Correct data is entered for 'State', 'Locality', 'Organisation', 'Organisation Unit' and 'Country'. Thanks in advance for your help!
     
    Last edited: Jun 12, 2013
  2. sipherdee

    sipherdee New Member HowtoForge Supporter

    Is it possible that this could be because "IPv4-Address" = "*" for our websites? "Enable SNI" is checked under 'ISPConfig > System > Server Config > Web > SSL Settings'.

    Thanks in advance if you have any idea!
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The ssl csr generation does not depend on the IP address, so thats not related. The most common problem is that one of the ssl data fields contains wrong data, e.g. openssl is sensitive when it comes to special chars.
     
  4. sipherdee

    sipherdee New Member HowtoForge Supporter

    Thanks for your answer but no special characters are being used, i.e.:

    State = QC
    Locality = Montreal
    Organisation = Organisation Name
    Organisation Unit = Name
    Country = Canada
    SSL Domain = host.domain.ca

    I also tried to change the state to 'Quebec' which gave the same result. Is there a log file or something that I could check for troubleshooting?
     

Share This Page