Unable to generate a CSR using the control panel (continued)

Discussion in 'ISPConfig 3 Priority Support' started by sipherdee, Jun 19, 2013.

  1. sipherdee

    sipherdee HowtoForge Supporter

    Hi! Last week, I started this thread:

    http://www.howtoforge.com/forums/showthread.php?t=62178

    I am still looking for a solution. What I am trying to do is to use ISPConfig to generate a CSR and nothing is happening when I select 'Create Certificate'.

    State = QC
    Locality = Montreal
    Organisation = Organisation Name
    Organisation Unit = Name
    Country = Canada
    SSL Domain = host.domain.ca

    As you can see, no special characters are being used. Do you know which log files that could help me troubleshoot this issue?

    I would appreciate if you have any ideas and I will post what I find here. Thanks in advance!
     
  2. till

    till Super Moderator

  3. sipherdee

    sipherdee HowtoForge Supporter

    Thanks Till, this is exactly what I needed!

    PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 186
    PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 187
    PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 188
    PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 197

    I removed 'disable_functions = exec' from our 'php.ini' file and I was able to create a self-signed certificate.
     
  4. till

    till Super Moderator

    You can place a copy of your php.ini in this path:

    /usr/local/ispconfig/server/lib/php.ini

    If this file exists, it will be used instaed of the global php.ini for the ISPConfig server process.
     

Share This Page