Unable to enable ISPconfig

Discussion in 'General' started by Srikanth1261, May 25, 2021.

  1. Srikanth1261

    Srikanth1261 Member

    Hi,
    I have webmin and ISPconfig in my server. I have upgraded from debian version 7 to debian version 10. After that I am unable to enable the ISPconfig. My all domains are in ISPconfig. Please help me. Please find the below output.


    [email protected]:~# /usr/local/ispconfig/server/server.sh
    PHP Warning: Declaration of db::query($queryString) should be compatible with mysqli::query($query, $resultmode = NULL) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 637
    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; system has a deprecated constructor in /usr/local/ispconfig/server/lib/classes/system.inc.php on line 31
    finished.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Install all packages according to Debian 10 perfect server guide and then update ispconfig.
     
  3. Srikanth1261

    Srikanth1261 Member

    I have done it already.
     
  4. Srikanth1261

    Srikanth1261 Member

  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. Srikanth1261

    Srikanth1261 Member

    Attached Files:

  7. Srikanth1261

    Srikanth1261 Member

    Please find the ouputs of you requested.
     

    Attached Files:

  8. Srikanth1261

    Srikanth1261 Member

    Another output
     

    Attached Files:

  9. Srikanth1261

    Srikanth1261 Member

    One more
     

    Attached Files:

  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Please post the output as text, in code tags (insert -> code)
     
  11. Srikanth1261

    Srikanth1261 Member

    Ok. Sorry
     
  12. Srikanth1261

    Srikanth1261 Member

    Code:
    [email protected]:~# systemctl status apache2
    * apache2.service - The Apache HTTP Server
       Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Tue 2021-05-25 16:51:10 CEST; 28min ago
         Docs: https://httpd.apache.org/docs/2.4/
      Process: 29179 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
    
    mag 25 16:51:10 ns369781.ovh.net systemd[1]: Starting The Apache HTTP Server...
    mag 25 16:51:10 ns369781.ovh.net apachectl[29179]: AH00526: Syntax error on line 60 of /etc/apache2/sites-enabled/acquaformosa.raccoltadifferenziata.eu.vhost-le-ssl.conf:
    mag 25 16:51:10 ns369781.ovh.net apachectl[29179]: Invalid command 'FCGIWrapper', perhaps misspelled or defined by a module not included in the server configuration
    mag 25 16:51:10 ns369781.ovh.net apachectl[29179]: Action 'start' failed.
    mag 25 16:51:10 ns369781.ovh.net apachectl[29179]: The Apache error log may have more information.
    mag 25 16:51:10 ns369781.ovh.net systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
    mag 25 16:51:10 ns369781.ovh.net systemd[1]: apache2.service: Failed with result 'exit-code'.
    mag 25 16:51:10 ns369781.ovh.net systemd[1]: Failed to start The Apache HTTP Server.
    
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Code:
    /etc/apache2/sites-enabled/acquaformosa.raccoltadifferenziata.eu.vhost-le-ssl.conf
    This is not a ISPConfig conf file. I suspect you have used the certbot command manually from the CLI, which caused this problem. You should never run certbot manually, let ISPConfig handle it. Remove that conf file.

    What is the output of the test script?
     
  14. Srikanth1261

    Srikanth1261 Member

    Code:
    [email protected]:~# cat htf_report.txt | more
    
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Debian GNU/Linux 10 (buster)
     
    [INFO] uptime:  17:21:32 up 2 days,  2:35,  3 users,  load average: 0,01, 0,04, 0,12
     
    [INFO] memory:
                  total        used        free      shared  buff/cache   available
    Mem:           15Gi       1,6Gi       9,1Gi        33Mi       4,9Gi        13Gi
    Swap:          29Gi          0B        29Gi
     
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.2
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.3.27-1~deb10u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.40
    [WARN] You are using an outdated php version.
    
    ##### PORT CHECK #####
    
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 80 (Webserver) seems NOT to be listening
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening
    [WARN] Port 22 (SSH server) seems NOT to be listening
    
    ##### MAIL SERVER CHECK #####
    
    
    ##### RUNNING SERVER PROCESSES #####
    
    [WARN] I could not determine which web server is running.
    [INFO] I found the following mail server(s):
        Unknown process (smtpd) (PID 12290)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 2610)
    [INFO] I found the following imap server(s):
        Dovecot (PID 2610)
    [INFO] I found the following ftp server(s):
        PureFTP (PID 3918)
    
    ##### LISTENING PORTS #####
    (only        ()
    Local        (Address)
    [anywhere]:995        (2610/dovecot)
    [localhost]:10025        (19685/master)
    [anywhere]:587        (19685/master)
    [anywhere]:587        (19685/master)
    [localhost]:11211        (3698/memcached)
    [anywhere]:110        (2610/dovecot)
    [anywhere]:143        (2610/dovecot)
    [anywhere]:10000        (4083/perl)
    [anywhere]:465        (9188/smtpd)
    [anywhere]:21        (3918/pure-ftpd)
    [localhost]:53        (3889/named)
    [anywhere]:23        (3706/inetd)
    [anywhere]:25        (12290/smtpd)
    [localhost]:953        (3889/named)
    [anywhere]:2202        (3796/sshd)
    [anywhere]:993        (2610/dovecot)
    *:*:*:*::*:995        (2610/dovecot)
    *:*:*:*::*:3306        (4248/mysqld)
    [localhost]10        (2610/dovecot)
    [localhost]43        (2610/dovecot)
    *:*:*:*::*:21        (3918/pure-ftpd)
    *:*:*:*::*:53        (3889/named)
    *:*:*:*::*:953        (3889/named)
    *:*:*:*::*:2202        (3796/sshd)
    *:*:*:*::*:993        (2610/dovecot)
    
    
    
    
    ##### IPTABLES #####
    
    
    
    
    ##### LET'S ENCRYPT #####
    
    
    
    [email protected]:~#
    
     
  15. Srikanth1261

    Srikanth1261 Member

    Code:
    [email protected]:~# lsb_release -a
    No LSB modules are available.
    Distributor ID:    Debian
    Description:    Debian GNU/Linux 10 (buster)
    Release:    10
    Codename:    buster
    
     
  16. Srikanth1261

    Srikanth1261 Member

    Code:
    [email protected]:~# php -v
    PHP 7.3.27-1~deb10u1 (cli) (built: Feb 13 2021 16:31:40) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.27, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.27-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies
    
     
  17. Srikanth1261

    Srikanth1261 Member

    Already posted. I haven't run anything manually. In the afternoon, apache was running fine. After following the following link https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/ It went down.
     
  18. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You are still running ISPConfig 3.0.X - ISPConfig 3.1 came out before the release of Debian 9, in 2016. So you have a heavily outdated and insecure setup.
    Install packages that are needed for 3.2:
    Code:
    sudo apt-get install bzip2 p7zip-full xz-utils lzip rar unrar-free goaccess dovecot-lmtpd
    Then upgrade to the latest version and let the installer reconfigure services:
    Code:
    cd /tmp
    wget https://www.ispconfig.org/downloads/ISPConfig-3.2.4.tar.gz
    tar xvfz ISPConfig-3.2.4.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Then set your OS to use PHP 7.3 for php-cgi:
    Code:
    update-alternatives --set php-cgi /usr/bin/php-cgi7.3
    After which step from https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/ did Apache go down?
     
  19. Srikanth1261

    Srikanth1261 Member

    Afrer the below step

    a2enmod suexec rewrite ssl actions include dav_fs dav auth_digest cgi headers actions proxy_fcgi alias
     
  20. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    What is the output of
    Code:
    cat /etc/apt/sources.list
    ?

    Have you ran
    Code:
    apt update && apt upgrade -y
    already?
     

Share This Page