Unable to create a dot-lock

Discussion in 'ISPConfig 3 Priority Support' started by jon, Jun 9, 2014.

  1. jon

    jon Member HowtoForge Supporter

    I'm seeing a lot of the following ...

    Jun 9 13:10:41 hosting maildrop[25272]: Unable to create a dot-lock at /var/vmail/domain.net/user/25272.0.hosting.
    Jun 9 13:10:41 hosting maildrop[25277]: Unable to create a dot-lock at /var/vmail/otherdomain.net/user/25277.0.hosting.
    Jun 9 13:10:41 hosting maildrop[25283]: Unable to create a dot-lock at /var/vmail/otherdomain/user2/25283.0.hosting.
    Jun 9 13:10:41 hosting maildrop[25285]: Unable to create a dot-lock at /var/vmail/anotherdomain.net/user/25285.0.hosting

    The permissions in /var/vmail/ are all vmail:vmail and this seems to be for a wide range of domains and users on those domains.

    Every day around this time there seems to be a huge spike in mail activity, and this looks to be related.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use courier or dovecot imap?
     
  3. jon

    jon Member HowtoForge Supporter

    I am using Courier
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the folders /var/vmail/domain.net/user are not existing? In this case the log entries are caused by the rejection process of courier when someone tries to send a email to a non existing email address. This is harmless and you can ignore it, if you want to get rid of the messages in the log, the do not use email domain aliases with courier and replace the domain aliases with email address aliases, so that only existing addresses are aliased and not all incoming emails. Another opton is to migrate to dovecot.
     
  5. jon

    jon Member HowtoForge Supporter

    I only use email aliases. If it is harmless I won't worry though.

    I have been getting very high load on the server a few times each day and have been trying to troubleshoot and saw a bunch of that dot-lock in the logs around the same time.

    Do you have any suggestions on how to track that down?
     
  6. jon

    jon Member HowtoForge Supporter

    I just wanted to update this ...

    If I run "mailq" I see a lot (currently 418) of messages in the queue with the error about the dot-lock.

    (temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/domain.net/user/11287.0.hosting.)

    Some are from several days ago.
     
  7. jon

    jon Member HowtoForge Supporter

    I've just discovered here ...

    http://oviedo.mx/postfix-temporary-...t-usrbinmaildrop-unable-to-create-a-dot-lock/

    That I had created my own problem when I disabled amavis. I had no commented out the second line, causing the dot-lock problem in this case.

    I have done so now and restarted postfix, all seems to be well with the dot-lock issue.

    I still have a problem with very high load at times, but it seems to be not related, as I had disabled amavis when the problem started.
     
  8. jon

    jon Member HowtoForge Supporter

    It turns out this problem still exists. I have re-enabled amavis and will monitor it.

    I have seen mail bouncing back to senders because of this error.
     

Share This Page