unable to configure website on ISPConfig 3

Discussion in 'Installation/Configuration' started by Raghu M, Jul 28, 2017.

  1. Raghu M

    Raghu M Member

    Hi friends, as i have configured ispconfig3 on ubuntu as all the installation went on fine but after adding my site unfortunately its not pointing my private ip so could u please let know the resolution, i followed all the instructions as mentioned in howtoforge, if required i can also provide access for my web server.
    my site url is yashkart.com
    my ip is 103.21.234.52
    Also request you to please find the attachments.
    Awaiting for earliest reply....
     

    Attached Files:

    Last edited: Jul 28, 2017
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Your registered nameservers (ns1.yashkart.com and ns2.yashkart.com) both have address 103.21.234.52, but the DNS server cannot be contacted at that address:
    Code:
    $ host YASHKART.COM 103.21.234.52
    ;; connection timed out; no servers could be reached
    
    Check your firewall(s).
     
  3. Raghu M

    Raghu M Member

    Hi Thanks for your response i have not activated firewall either in os level or router level as both are disabled. any other suggestions.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check with:

    dig @localhost yashkart.com

    command on the server if you can resolve the domain locally. Is the server in a datacenter or do you run it at home or in office?
     
  5. Raghu M

    Raghu M Member

    Hi Till Good Day, am running this server in my home and when i run the above command i got below mentioned results.

    [email protected]:~# dig @localhost yashkart.com

    ; <<>> DiG 9.10.3-P4-Ubuntu <<>> @localhost yashkart.com
    ; (2 servers found)
    ;; global options: +cmd
    ;; connection timed out; no servers could be reached
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, so your BIND dns server seems not to be running. Try to restart it and check the syslog file of the Linux system for errors.
     
  7. Raghu M

    Raghu M Member

    ok thanks for u r reply, request you to please find the status report of bind

    [email protected]:~# service bind9 status
    ● bind9.service - BIND Domain Name Server
    Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: en
    Drop-In: /run/systemd/generator/bind9.service.d
    └─50-insserv.conf-$named.conf
    Active: failed (Result: exit-code) since Tue 2017-08-01 13:14:31 IST; 31s ago
    Docs: man:named(8)
    Process: 5271 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
    Process: 5258 ExecStart=/usr/sbin/named -f -u bind (code=exited, status=1/FAIL
    Main PID: 5258 (code=exited, status=1/FAILURE)

    Aug 01 13:14:31 softpro9 named[5258]: using 4 UDP listeners per interface
    Aug 01 13:14:31 softpro9 named[5258]: using up to 4096 sockets
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration from '/etc/bind/name
    Aug 01 13:14:31 softpro9 named[5258]: /etc/bind/named.conf.options:26: unknown o
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration: failure
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Main process exited, code=ex
    Aug 01 13:14:31 softpro9 rndc[5271]: rndc: connect failed: 127.0.0.1#953: connec
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Control process exited, code
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Unit entered failed state.
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Failed with result 'exit-cod
    lines 1-20/20 (END)...skipping...
    ● bind9.service - BIND Domain Name Server
    Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
    Drop-In: /run/systemd/generator/bind9.service.d
    └─50-insserv.conf-$named.conf
    Active: failed (Result: exit-code) since Tue 2017-08-01 13:14:31 IST; 31s ago
    Docs: man:named(8)
    Process: 5271 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
    Process: 5258 ExecStart=/usr/sbin/named -f -u bind (code=exited, status=1/FAILURE)
    Main PID: 5258 (code=exited, status=1/FAILURE)

    Aug 01 13:14:31 softpro9 named[5258]: using 4 UDP listeners per interface
    Aug 01 13:14:31 softpro9 named[5258]: using up to 4096 sockets
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration from '/etc/bind/named.conf'
    Aug 01 13:14:31 softpro9 named[5258]: /etc/bind/named.conf.options:26: unknown option 'listen-on-v4'
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration: failure
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 13:14:31 softpro9 rndc[5271]: rndc: connect failed: 127.0.0.1#953: connection refused
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Control process exited, code=exited status=1
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Unit entered failed state.
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Failed with result 'exit-code'.
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    lines 1-20/20 (END)...skipping...
    ● bind9.service - BIND Domain Name Server
    Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
    Drop-In: /run/systemd/generator/bind9.service.d
    └─50-insserv.conf-$named.conf
    Active: failed (Result: exit-code) since Tue 2017-08-01 13:14:31 IST; 31s ago
    Docs: man:named(8)
    Process: 5271 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
    Process: 5258 ExecStart=/usr/sbin/named -f -u bind (code=exited, status=1/FAILURE)
    Main PID: 5258 (code=exited, status=1/FAILURE)

    Aug 01 13:14:31 softpro9 named[5258]: using 4 UDP listeners per interface
    Aug 01 13:14:31 softpro9 named[5258]: using up to 4096 sockets
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration from '/etc/bind/named.conf'
    Aug 01 13:14:31 softpro9 named[5258]: /etc/bind/named.conf.options:26: unknown option 'listen-on-v4'
    Aug 01 13:14:31 softpro9 named[5258]: loading configuration: failure
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 13:14:31 softpro9 rndc[5271]: rndc: connect failed: 127.0.0.1#953: connection refused
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Control process exited, code=exited status=1
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Unit entered failed state.
    Aug 01 13:14:31 softpro9 systemd[1]: bind9.service: Failed with result 'exit-code'.
    ~
     
  8. Raghu M

    Raghu M Member

    Hi earlier in /etc/bind/named.conf.options i have changed 'listen-on-v6' to 'listen-on-v4' now i replaced with 'listen-on-v6' so now am getting this status report

    [email protected]:~# service bind9 status
    ● bind9.service - BIND Domain Name Server
    Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
    Drop-In: /run/systemd/generator/bind9.service.d
    └─50-insserv.conf-$named.conf
    Active: active (running) since Tue 2017-08-01 13:22:24 IST; 2s ago
    Docs: man:named(8)
    Process: 5271 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
    Main PID: 5610 (named)
    Tasks: 11
    Memory: 17.7M
    CPU: 161ms
    CGroup: /system.slice/bind9.service
    └─5610 /usr/sbin/named -f -u bind

    Aug 01 13:22:24 softpro9 named[5610]: zone yashkart.com/IN: loaded serial 2017072904
    Aug 01 13:22:24 softpro9 named[5610]: all zones loaded
    Aug 01 13:22:24 softpro9 named[5610]: running
    Aug 01 13:22:24 softpro9 named[5610]: zone yashkart.com/IN: sending notifies (serial 2017072904)
    Aug 01 13:22:25 softpro9 named[5610]: network unreachable resolving 'dlv.isc.org/DNSKEY/IN': 2001:500:60::30#53
    Aug 01 13:22:25 softpro9 named[5610]: network unreachable resolving 'dlv.isc.org/DLV/IN': 2001:500:60::30#53
    Aug 01 13:22:26 softpro9 named[5610]: network unreachable resolving 'ns1.isc.ultradns.net/A/IN': 2001:503:c27::2:30#53
    Aug 01 13:22:26 softpro9 named[5610]: network unreachable resolving 'ns2.isc.ultradns.net/A/IN': 2001:503:c27::2:30#53
    Aug 01 13:22:26 softpro9 named[5610]: network unreachable resolving 'ns2.isc.ultradns.net/AAAA/IN': 2001:503:c27::2:30#53
    Aug 01 13:22:26 softpro9 named[5610]: network unreachable resolving 'ns1.isc.ultradns.net/AAAA/IN': 2001:503:c27::2:30#53
    [email protected]:~# ^C
    [email protected]:~#
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, so it is running again. Now try:

    dig @localhost yashkart.com
     
  10. Raghu M

    Raghu M Member

    hi thsi is the out put for
    [email protected]:~# dig @localhost yashkart.com

    ; <<>> DiG 9.10.3-P4-Ubuntu <<>> @localhost yashkart.com
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33355
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;yashkart.com. IN A

    ;; ANSWER SECTION:
    yashkart.com. 3600 IN A 192.168.0.140

    ;; AUTHORITY SECTION:
    yashkart.com. 3600 IN NS ns1.yashkart.com.
    yashkart.com. 3600 IN NS ns2.yashkart.com.

    ;; ADDITIONAL SECTION:
    ns1.yashkart.com. 3600 IN A 192.168.0.140
    ns2.yashkart.com. 3600 IN A 192.168.0.140

    ;; Query time: 1 msec
    ;; SERVER: ::1#53:):1)
    ;; WHEN: Tue Aug 01 13:38:29 IST 2017
    ;; MSG SIZE rcvd: 125

    [email protected]:~#
     
  11. Raghu M

    Raghu M Member

    Mr. Till am awaiting for your suggestions.
     

Share This Page