Unable to add ssl suport with Nginx

Discussion in 'Installation/Configuration' started by jimbo4215, Jan 27, 2019.

  1. jimbo4215

    jimbo4215 New Member

    I follow this tuto : https://www.howtoforge.com/tutorial/perfect-server-ubuntu-18-04-nginx-bind-dovecot-and-ispconfig-3/
    Unfortunately Nginx doesn't listen on port 443 and I'm not be able to enable HTTPS and HTTP2.
    vhost file is created but without any ssl option.

    Have you a idea ? it's a certbot issue ?

    certbot log :

    certbot.errors.FailedChallenges: Failed authorization procedure. www.jimbo.advertis.cloud (http-01): urn:ietf:params:acme:error:dns :: DNS problem: SERVFAIL looking up CAA for advertis.cloud, jimbo.advertis.cloud (http-01): urn:ietf:params:acme:error:dns :: DNS problem: SERVFAIL looking up CAA for advertis.cloud
    dig SOA jimbo2.advertis.cloud +short
    s1.advertis.cloud.  2019012701 7200 540 604800 3600
    Last edited: Jan 27, 2019
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    SSL is not enabled when there is no SSL cert and as the error message says, a Let's encrypt SSL cert could not be retrieved from Let#s encrypt. Probably your domain advertis.cloud as a CAA record which forbids LE certificates for this domain and it's subdomains.
  3. jimbo4215

    jimbo4215 New Member

    thanks I fixed it ! A entry was missing for advertis.cloud
    certificat generate and ssl enabled

    till likes this.

Share This Page