unable to add MX records for sites

Discussion in 'Installation/Configuration' started by mspIggy, Jul 8, 2008.

  1. mspIggy

    mspIggy New Member

    i am very, very confused

    this dns Domain >Options > Records menu for any given sites seems logial and very easy to use...

    however, when i go to my site..

    iggyweb.com, and try to create a MX, new with mailserver name of

    iggyweb.com (no hose name) i get an error:

    This or a similar MX Record does already exist in this zone.

    zone? what zone...

    there is no mx record for iggweb onder the iggyweb site in DNS manage

    there is no other spot where such a record can be published -- unless i am missing somehting?

    what is going on here?

    how do we properly set up mail?

    many thanks
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. mspIggy

    mspIggy New Member

    no no...

    this is a newly added domain

    this is a new install of ubuntu and ISPConfig

    heretofore, there were no 'nowebsites' also there were no 'mx' records intentionally created - i thought maybe they were automatically made with the site creation?

    the recycle bin is empty

    this happens on ALL domains i have added to server so far...

    there is a default mx record there (server hostname, server name)

    this is not so good...

    what is going on here?

    many thanks
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /etc/bind/
  5. mspIggy

    mspIggy New Member

    many thanks

    i am feeling a bit silly

    i had been checking the add dns-MX box

    this added a default MX record - server hostname.website.com

    and this is not a real website so the email never worked

    once i deleted this default MX record - and made a new one manually - things work...

    thank you


Share This Page