Unable to add additional serial device

Discussion in 'Installation/Configuration' started by beouioui, Nov 12, 2006.

  1. beouioui

    beouioui New Member


    I have a 4 ports PCI serial board. When installed with Ubuntu 6.10. Everything is recognized except only 3 of the 4 ports are installed.
    The reason behind is that the motherboard integrated serial port is recognised and installed. So it means that out of the 4 available /dev/ttyS devices all are user (ttyS0 by the motherboard serial port and the 3 ttyS left by my addon card).
    I would like to add one additional device to enable the last serial port. Here is what I already tried
    I run "mknod -m 666 /dev/ttyS4 c 4 68" I have no error message and ls /dev/ttyS4 shows the file but when I run the command "setserial /dev/ttyS4 port 0xa000 irq 177 uart 16550a baud_base 115200" I have the following message "No such device or address"
    The second method I tried is to run the following command "./MAKEDEV ttyS4" which returns the following message "udev active, devices will be created in /dev/.static/dev/"

    I am a litlle stuck.

    Could someone provide some hint. I would appreciate.

    Thank you


Share This Page