Unable to access /webmail (MultiServer)

Discussion in 'ISPConfig 3 Priority Support' started by NeonTigerUK, Oct 8, 2016.

  1. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Hi All

    I am unable to access /webmail on any of my domains on my Multi-Server setup

    can anyone please advise how i can (re)gain access.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The webmail url is freely configurable in ispconfig and has to be set to the URL where the actual webmail application is installed. On which server did you install which webmail application and which alias have you chosen for it?
     
  3. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    app was installed to web1, on /webmail, im wondering if there is a problem with the mail being on mail1
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If the alias is /webmail, then you must be able to reach it on each domain that points to this server. Test if it is not /roundcube as alias. If webmai and mailserver are on different servers then you have to set the mail server as smtp and imap server in the config file of the webmail client and add the Ip of your web server to the mynetworks line of the mail server (postfix main.cf).
     
  5. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    i could always point webmail.at the mail server and add roundcube and horde to it, and add teh webmail subdomain in to the DNS for each domain that has email..... but .. what do i add to the conf file to make webmail. work across all domains instead of /webmail or /roundcube?

    I could assume i'd need to enable pache on th email server too if i use that method - i didnt enable apache as i wont be using & didnt install mailman
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not install webmail at the mail server, just do the changes in the webmail config I pointed out above.
     
  7. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    I can now get roundcube to display - removing it and re-installing it solved the problem, but not i get a Connection To IMAP Server failed error
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you set the hostname of the IMAP server in the roundcube configuration file?
     
  9. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    $config['default_host'] = '%n = mail server fqdn';
    $config['smtp_server'] = '%n = mail server fqdn';
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Replace %n with the hostname of your mail server.

    $config['default_host'] = 'my.mailserver.tld';
    $config['smtp_server'] = 'my.mailserver.tld';
     
  11. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Thanks Till - thats working now :)

    For the clients dedicated mail server, if I add Roundcube, and configure apache will that work fine for just that server?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I would just use "localhost" if roundcube and the mail server are on the same system.
     
  13. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    I have another client who on their webserver wants horde, I'm currently following the guide here ... Install Horde 5 Webmail for ISPConfig on Debian Jessie through PEAR

    I've got to the Split reads to a different server ...

    How do I make it look at the main mail server? and also how would I add the main Horde Groupware as I can find no guide on HTF
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I never used horde.
     
  15. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    they only want Horde for Card and Cal Dav, if you can suggest something better that is not owncloud, tried it - couldnt make it sync to iphone / ipad
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont run a CardDav or CalDav server here.
     

Share This Page