Unable to access internet with named service started

Discussion in 'Server Operation' started by icompany, Dec 30, 2009.

  1. icompany

    icompany New Member

    Hi.... I am unable to access internet with named service started. Have to stop named service to access internet. Verified zone records are correct. I also have two other issues that might be related to this one.

    1) unable to access internet
    2) cannot recieve send or recieve mail locally , Can send mail externaly only
    3) SSL does not work in apache. I am not able to get to https of site. Http works. I am unable to start apache with ssl installed in my virtual site from yasts http. I only have one site setup. Opensuse docs recommend setting up this way for future additional sites. When the system adds the ( <IFDefine SSL> openssl on </IFDefine> ) to my virtual site this is when I am unable to access anything for the site.


    Thanks
     
    Last edited: Jan 9, 2010
  2. icompany

    icompany New Member

    Some additional info . I am using thunderbird, postfix and squirrelmail as my mail system. Below is the Mail log output. Please let me know if someone could discypher the misconfig from this file? I'm hitting a wall at this point?



    should I be worried about the max connection count 1 and max cache size 1 . In the file above.

    Thanks
     
    Last edited: Jan 9, 2010
  3. falko

    falko Super Moderator

    What's in /etc/resolv.conf?
     
  4. icompany

    icompany New Member

    Code:
    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    #     NETCONFIG_DNS_STATIC_SEARCHLIST
    #     NETCONFIG_DNS_STATIC_SERVERS
    #     NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    #     NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    nameserver 65.32.1.65
    nameserver 65.32.1.70
    nameserver 192.168.1.5
    
     
    Last edited: Jan 9, 2010
  5. icompany

    icompany New Member

    Some additional info: I'm connected to my broadband cable modem through a local router hence the local IP's. The Pri / Sec ( 65.32.1 ) are from the ISP.
     
    Last edited: Jan 9, 2010
  6. falko

    falko Super Moderator

    What happens when you use
    Code:
    nameserver 145.253.2.75
    as the first nameserver in /etc/resolv.conf?
     
  7. icompany

    icompany New Member

    what does the above nameserver represent . It seems to have fixed the original problem of not being able to connect to the internet while named is running. I still am unable to receive mail. Looks like I can send and it reaches the mail server. Says I have a loop back. Thank you for solving my first issue.

    Code:
    
    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    #     NETCONFIG_DNS_STATIC_SEARCHLIST
    #     NETCONFIG_DNS_STATIC_SERVERS
    #     NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    #     NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    
    nameserver 145.253.2.75
    nameserver 65.32.1.65
    nameserver 65.32.1.70
    nameserver 192.168.1.5
    
     
    Last edited: Jan 9, 2010
  8. falko

    falko Super Moderator

    It's a nameserver of a German ISP that I know works. Please remove
    Code:
    nameserver 65.32.1.65
    nameserver 65.32.1.70
    from your resolv.conf as they don't seem to work.

    Please add inetmining.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.
     
  9. icompany

    icompany New Member

    updated above resolv.conf for nameserver and added inetmining.com to mydestination. Still receive mail bounce on 2 issue. first issue resolved. Thank you
     
    Last edited: Jan 9, 2010

Share This Page