unable to access 2nd and 3rd ftp sites

Discussion in 'Installation/Configuration' started by rebeltaz, Mar 17, 2014.

  1. rebeltaz

    rebeltaz New Member

    I have rebuilt my web server due to being hacked. I had ispConfig working fine before, but now I cannot seem to get it to work correctly again. Version 3 is MUCH different from what i had in the past!

    I have installed three sites under a single client. Under each site, I have added an FTP user. I am able to access the first FTP user/site I created, but not the second or third.

    Can some one please help me figure this out?

    [strike]I noticed I keep getting this error message in the Monitor logs:
    CA path error, file does not exist:admin/openssl.cnf[/strike]
    I found the problem with this.

    Maybe this has something to do with it? When I installed the server software (ubuntu 12.04 lts server) when it asked for the hostname, I wasn't sure what to put there since it was to host three different sites. I used server.RobotsAndComputers.com. Curiously that is the ftp site that works. All three web sites are still accessable though.

    -further edit-
    I may want to add that PHP doesn't work correctly either. I am using a counter and the paramaters are not being passed from the web page to the script. :( Nor are my own 404 error pages being read, but rather generic versions.

    NOTHING is working like it should!
    Last edited: Mar 17, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Tutorial did you use to install the server? Which errors do you get in the error.log of the websites were ypu have the php problem? Which errors do you get in the ftp client when you use the second ftp user to connect to the second site?
  3. rebeltaz

    rebeltaz New Member

    I used this tutorial - http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3 - but I left off BIND and MyDNS since I didn't need those.

    The error.log has these lines:
    [Mon Mar 17 01:57:54 2014] [error] [client] File does not exist: /var/www/robotsandcomputers.com/web/robots/wwcomplaint.htm)
    which does exist.
    [Mon Mar 17 01:31:02 2014] [error] [client] client denied by server configuration: /var/www/robotsandcomputers.com/web/counter/counter.php, referer: http://www.robotsandcomputers.com/robots/
    [Mon Mar 17 01:46:56 2014] [warn] [client] mod_fcgid: stderr: PHP Warning:  include(): Failed opening '' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/clients/client1/web1/web/robots/personal.php on line 148
    [Mon Mar 17 02:01:42 2014] [warn] [client] mod_fcgid: stderr: PHP Notice:  Undefined variable: HTTP_GET_VARS in /var/www/clients/client1/web1/web/robots/personal.php on line 130
    [Mon Mar 17 02:01:42 2014] [warn] [client] mod_fcgid: stderr: PHP Warning:  include(): Failed opening '' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/clients/client1/web1/web/robots/personal.php on line 148

    When I try to connect, it says:
    Status: Resolving address of www.ShelbyCycle.com
    Status: Connecting to
    Error: Connection timed out
    Error: Could not connect to server
    Status: Waiting to retry...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so please post the output of:

    ls -la /var/www/robotsandcomputers.com/web/robots/wwcomplaint.htm

    Either the IP emntioned in the error does not belong to this server, check with:


    command or a firewal blocks ftp connnections.
  5. rebeltaz

    rebeltaz New Member

    -rw-r--r-- 1 web1 client1 8222 Mar 16 22:53 /var/www/robotsandcomputers.com/web/robots/wwcomplaint.htm
    D'oh. OK so the ip isn't being redirected to my local server ip address. Nothing has changed with the DNS records through 1&1, so...
    This is the output when connected through ftp to the first site that does work:
    Status:	Resolving address of www.RobotsAndComputers.com
    Status:	Connecting to
    Status:	Connection established, waiting for welcome message...
  6. rebeltaz

    rebeltaz New Member

    Hmm... well I can log in to the ftp servers through my local network, but it's odd that the first server is translating correctly from my public IP address to my local IP.

    I still need to figure out why php isn't working, so I guess I need to start a new topic for that.

Share This Page