Unable send receive emails

Discussion in 'Installation/Configuration' started by vassilis3, May 17, 2007.

  1. vassilis3

    vassilis3 New Member

    Hello
    I try to read many theads but i can't find solution
    Like a title says unable send receive emails
    isp is over debian
     
  2. Hans

    Hans Moderator

    Which MTA do you use? Postfix?
    What's within the log files?
     
  3. vassilis3

    vassilis3 New Member

    Mta


    MTA: postfix
    which log file /var/log/mail.log? the lastest lines is

    May 17 20:17:35 server1 postfix/smtpd[10696]: connect from bzq-88-154-39-23.red.bezeqint.net[88.154.39.23]
    May 17 20:17:38 server1 postfix/smtpd[10696]: 1D5AE1F3BD4: client=bzq-88-154-39-23.red.bezeqint.net[88.154.39.23]
    May 17 20:17:39 server1 postfix/cleanup[10692]: 1D5AE1F3BD4: message-id=<000001c798a7$4781d580$0100007f@localhost>
    May 17 20:17:39 server1 postfix/qmgr[9469]: 1D5AE1F3BD4: from=<rockofroseville.com@fragemporium.net>, size=23226, nrcpt=1 (qu$
    May 17 20:17:39 server1 postfix/smtp[10075]: 1D5AE1F3BD4: to=<web22_promos@server1.grikservers.com>, orig_to=<swarovski@promos$
    May 17 20:17:40 server1 postfix/cleanup[10798]: F3ED71F3BD8: message-id=<20070517171739.F3ED71F3BD8@server1.grikservers.com>
    May 17 20:17:40 server1 postfix/qmgr[9469]: F3ED71F3BD8: from=<>, size=25346, nrcpt=1 (queue active)
    May 17 20:17:40 server1 postfix/bounce[10076]: 1D5AE1F3BD4: sender non-delivery notification: F3ED71F3BD8
    May 17 20:17:40 server1 postfix/qmgr[9469]: 1D5AE1F3BD4: removed
    May 17 20:17:40 server1 courierpop3login: Disconnected, ip=[::ffff:10.84.234.50]
    May 17 20:17:40 server1 postfix/smtpd[10696]: disconnect from bzq-88-154-39-23.red.bezeqint.net[88.154.39.23]
    May 17 20:17:40 server1 postfix/smtp[9908]: warning: no MX host for fragemporium.net has a valid address record
    May 17 20:17:40 server1 postfix/smtp[9908]: F3ED71F3BD8: to=<rockofroseville.com@fragemporium.net>, relay=none, delay=0.71, d$
    May 17 20:17:40 server1 postfix/qmgr[9469]: F3ED71F3BD8: removed
    May 17 20:17:41 server1 courierpop3login: Connection, ip=[::ffff:10.84.234.50]
    May 17 20:17:41 server1 courierpop3login: LOGIN, user=web17_antespiti, ip=[::ffff:10.84.234.50]
    May 17 20:17:41 server1 courierpop3login: LOGOUT, user=web17_antespiti, ip=[::ffff:10.84.234.50], top=0, retr=0, rcvd=12, sen$
    May 17 20:17:42 server1 postfix/smtpd[10771]: connect from cable201-233-65-217.epm.net.co[201.233.65.217]
    May 17 20:17:42 server1 postfix/smtpd[10721]: warning: 91.xx.xx.150: address not listed for hostname srv.grikservers.com
    May 17 20:17:42 server1 postfix/smtpd[10721]: connect from unknown[91.xx.xx.150]
    May 17 20:17:42 server1 postfix/smtpd[10721]: NOQUEUE: reject: RCPT from unknown[91.xx.xx.150]: 554 5.7.1 <basilis3@gmail.$
    May 17 20:17:42 server1 postfix/smtpd[10721]: NOQUEUE: reject: RCPT from unknown[91.xx.xx.150]: 554 5.7.1 <basilis3@gmail.$
    May 17 20:17:42 server1 postfix/smtpd[10721]: disconnect from unknown[91.xx.xx.150]
    May 17 20:17:42 server1 courierpop3login: Connection, ip=[::ffff:91.xx.xx.150]
    May 17 20:17:42 server1 courierpop3login: LOGIN, user=web22_promos, ip=[::ffff:91.xx.xx.150]
    May 17 20:17:42 server1 courierpop3login: LOGOUT, user=web22_promos, ip=[::ffff:91.xx.xx.150], top=0, retr=0, rcvd=12, sent=$
    May 17 20:17:46 server1 courierpop3login: Connection, ip=[::ffff:10.84.234.50]
    May 17 20:17:46 server1 courierpop3login: LOGIN, user=web20_yialos, ip=[::ffff:10.84.234.50]
    May 17 20:17:46 server1 courierpop3login: LOGOUT, user=web20_yialos, ip=[::ffff:10.84.234.50], top=0, retr=0, rcvd=12, sent=39$
    May 17 20:17:47 server1 postfix/smtpd[10771]: 298BE1F3BD4: client=cable201-233-65-217.epm.net.co[201.233.65.217]
    May 17 20:17:52 server1 postfix/cleanup[10801]: 298BE1F3BD4: message-id=<B96520F7.8277134@bcbsde.com>
    May 17 20:17:52 server1 postfix/qmgr[9469]: 298BE1F3BD4: from=<DomingoShelton71@yahoo.com>, size=2296, nrcpt=1 (queue active)
    May 17 20:17:52 server1 postfix/smtp[9971]: 298BE1F3BD4: to=<web22_promos@server1.grikservers.com>, orig_to=<awov@promos.gr>, $
    May 17 20:17:52 server1 postfix/cleanup[10692]: DD6FB1F3BD8: message-id=<20070517171752.DD6FB1F3BD8@server1.grikservers.com>
    May 17 20:17:52 server1 postfix/qmgr[9469]: DD6FB1F3BD8: from=<>, size=4452, nrcpt=1 (queue active)
    May 17 20:17:52 server1 postfix/bounce[10076]: 298BE1F3BD4: sender non-delivery notification: DD6FB1F3BD8
    May 17 20:17:52 server1 postfix/qmgr[9469]: 298BE1F3BD4: removed
    May 17 20:17:54 server1 postfix/smtpd[10771]: disconnect from cable201-233-65-217.epm.net.co[201.233.65.217]
     
  4. Hans

    Hans Moderator

    Do you use the Maildir format and if so, did you enable it?
    Can you post here the content of your /etc/postfix/main.cf ?
     
    Last edited: May 17, 2007
  5. vassilis3

    vassilis3 New Member


    Maildir enabled
    See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = server1.grikservers.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.grikservers.com, localhost.grikservers.com, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  6. Hans

    Hans Moderator

    That looks ok..But i asume that you've enabled Maildir then within ISPConfig as it is not enabled within your etc/postfix/main.cf file with the line:
    home_mailbox = Maildir/

    When i open a telnet session to your mailserver with telnet server1.grikservers.com 25 , i can not establish a connection.

    So, i like to know what is the output of: netstat -tap
     
  7. vassilis3

    vassilis3 New Member


    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:1283 *:* LISTEN 2380/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 2003/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1683/portmap
    tcp 0 0 *:81 *:* LISTEN 2557/ispconfig_http
    tcp 0 0 *:auth *:* LISTEN 2184/inetd
    tcp 0 0 srv.grikservers:domain *:* LISTEN 11890/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 11890/named
    tcp 0 0 *:ftp *:* LISTEN 2909/proftpd: (acce
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 11890/named
    tcp 0 0 *:smtp *:* LISTEN 9466/master
    tcp 0 0 localhost.localdom:4175 localhost.localdoma:www TIME_WAIT -
    tcp 0 61 srv.grikservers.c:smtp 85-220-70-254.dsl:60490 FIN_WAIT1 -
    tcp 0 1 srv.grikservers.c:4096 60.190.203.33:smtp FIN_WAIT1 -
    tcp 0 0 srv.grikservers.c:4945 cf-2.marcatel.net.:smtp TIME_WAIT -
    tcp 0 0 srv.grikservers.c:smtp 58.18.72-86.rev.g:55227 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:1150 spf12.us4.outblaze:smtp ESTABLISHED12403/smtp
    tcp 0 0 localhost.localdoma:ftp localhost.localdom:2709 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:smtp pool-68-161-201-17:2557 TIME_WAIT -
    tcp 0 61 srv.grikservers.c:smtp host-89-229-165-51:2523 FIN_WAIT1 -
    tcp 0 0 srv.grikservers.c:smtp corp-200-105-255-1:3871 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:2537 aa.f5.3845.static.:smtp ESTABLISHED-
    tcp 0 14 srv.grikservers.c:smtp 41.212.164.19:4453 ESTABLISHED-
    tcp 0 37 srv.grikservers.c:smtp chello087206082022:4044 ESTABLISHED12159/smtpd
    tcp 0 0 srv.grikservers.c:2175 spf-jail2.us4.outb:smtp ESTABLISHED12437/smtp
    tcp 0 0 srv.grikservers.c:smtp 103.112.192-77.rev:1187 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:smtp 90-190-58-120-wifi:2415 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:smtp 218.209.83.135:2919 TIME_WAIT -
    tcp 0 0 srv.grikservers.c:smtp 200-205-4-140.oque:3045 TIME_WAIT -
    tcp6 0 0 *:imaps *:* LISTEN 2152/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 2175/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 2157/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 2140/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 2731/apache2
    tcp6 0 0 *:ssh *:* LISTEN 2337/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 11890/named
    tcp6 0 0 *:smtp *:* LISTEN 9466/master
    tcp6 0 0 *:https *:* LISTEN 2731/apache2
    tcp6 0 0 srv.grikservers.co:ssh ::ffff:10.86.90.13:1515 ESTABLISHED12366/1
    tcp6 0 888 srv.grikservers.co:ssh ::ffff:10.84.234.5:1181 ESTABLISHED5280/0

    note : the grikservers domain isn't real I have changes it
     
  8. Hans

    Hans Moderator

    Are you really sure that you enabled the Maildir checkbox in ISPConfig under management > server > settings on the mail tab ?

    Ports 25,110 & 143 are not blocked by a firewall?
     
  9. vassilis3

    vassilis3 New Member


    double checked

    ports are open
    maildir checked
     
  10. edge

    edge HowtoForge Supporter

    small note that if you use the ISPconfig Portscanner they always show open!

    The sent problem could be an ISP that is blocking the ports
    The receive problem could be a bad MX setup.

    Did you have a look at your NS with www.dnsreport.com (enter the domain in the DNS report box, and hit [DNS report] )

    Post all (if any) FAIL's back here
     
  11. vassilis3

    vassilis3 New Member

     
  12. vassilis3

    vassilis3 New Member

    MX INFO MX Record Your 1 MX record is:

    10 srv.grikservers.com. [TTL=86400] IP=91.xxx.xxx.150 [TTL=86400] [*U]
    PASS Low port test OK. Our local DNS server that uses a low port number can get your MX record. Some DNS servers are behind firewalls that block low port numbers. This does not guarantee that your DNS server does not block low ports (this specific lookup must be cached), but is a good indication that it does not.
    PASS Invalid characters OK. All of your MX records appear to use valid hostnames, without any invalid characters.
    PASS All MX IPs public OK. All of your MX records appear to use public IPs. If there were any private IPs, they would not be reachable, causing slight mail delays, extra resource usage, and possibly bounced mail.
    PASS MX records are not CNAMEs OK. Looking up your MX record did not just return a CNAME. If an MX record query returns a CNAME, extra processing is required, and some mail servers may not be able to handle it.
    PASS MX A lookups have no CNAMEs OK. There appear to be no CNAMEs returned for A records lookups from your MX records (CNAMEs are prohibited in MX records, according to RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3).

    PASS MX is host name, not IP OK. All of your MX records are host names (as opposed to IP addresses, which are not allowed in MX records).
    INFO Multiple MX records NOTE: You only have 1 MX record. If your primary mail server is down or unreachable, there is a chance that mail may have troubles reaching you. In the past, mailservers would usually re-try E-mail for up to 48 hours. But many now only re-try for a couple of hours. If your primary mailserver is very reliable (or can be fixed quickly if it goes down), having just one mailserver may be acceptable.
    PASS Differing MX-A records OK. I did not detect differing IPs for your MX records (this would happen if your DNS servers return different IPs than the DNS servers that are authoritative for the hostname in your MX records).
    PASS Duplicate MX records OK. You do not have any duplicate MX records (pointing to the same IP). Although technically valid, duplicate MX records can cause a lot of confusion, and waste resources.

    PASS Reverse DNS entries for MX records OK. The IPs of all of your mail server(s) have reverse DNS (PTR) entries. RFC1912 2.1 says you should have a reverse DNS for all your mail servers. It is strongly urged that you have them, as many mailservers will not accept mail from mailservers with no reverse DNS entry. Note that this information is cached, so if you changed it recently, it will not be reflected here (see the www.DNSstuff.com Reverse DNS Tool for the current data). The reverse DNS entries are:

    150.206.132.91.in-addr.arpa cust-206-150.on2.ontelecoms.gr. [TTL=10768]

    Mail PASS Connect to mail servers OK: I was able to connect to all of your mailservers.
    PASS Mail server host name in griting OK: All of your mailservers have their host name in the griting:

    srv.grikservers.com:
    220 srv.grikservers.com ESMTP Postfix (Debian/GNU)
    PASS Acceptance of NULL <> sender OK: All of your mailservers accept mail from "<>". You are required (RFC1123 5.2.9) to receive this type of mail (which includes reject/bounce messages and return receipts).
    PASS Acceptance of postmaster address OK: All of your mailservers accept mail to postmaster@promos.com (as required by RFC822 6.3, RFC1123 5.2.7, and RFC2821 4.5.1).

    PASS Acceptance of abuse address OK: All of your mailservers accept mail to abuse@promos.com.
    INFO Acceptance of domain literals WARNING: One or more of your mailservers does not accept mail in the domain literal format (user@[0.0.0.0]). Mailservers are technically required RFC1123 5.2.17 to accept mail to domain literals for any of its IP addresses. Not accepting domain literals can make it more difficult to test your mailserver, and can prevent you from receiving E-mail from people reporting problems with your mailserver. However, it is unlikely that any problems will occur if the domain literals are not accepted (mailservers at many common large domains have this problem).

    srv.grikservers.com's postmaster@[91.xxx.xxx.150] response:
    >>> RCPT TO:<postmaster@[91.xxx.xxx.150]>
    <<< 554 5.7.1 <postmaster@[91.xxx.xxx.150]>: Relay access denied
    PASS Open relay test OK: All of your mailservers appear to be closed to relaying. This is not a thorough check, you can get a thorough one here.

    srv.grikservers.com OK: 554 5.7.1 <Not.abuse.see.www.DNSreport.com.from.IP.91.xxx.xxx.150@DNSreport.com>: Relay access denied
    WARN SPF record Your domain does not have an SPF record. This means that spammers can easily send out E-mail that looks like it came from your domain, which can make your domain look bad (if the recipient thinks you really sent it), and can cost you money (when people complain to you, rather than the spammer). You may want to add an SPF record ASAP, as 01 Oct 2004 was the target date for domains to have SPF records in place (Hotmail, for example, started checking SPF records on 01 Oct 2004).
    WWW INFO WWW Record Your www.promos.com A record is:

    www.promos.com. A 91.xxx.xxx.150 [TTL=86400] [*U]
    PASS All WWW IPs public OK. All of your WWW IPs appear to be public IPs. If there were any private IPs, they would not be reachable, causing problems reaching your web site.
    PASS CNAME Lookup OK. Some domains have a CNAME record for their WWW server that requires an extra DNS lookup, which slightly delays the initial access to the website and use extra bandwidth. There are no CNAMEs for www.promos.com, which is good.
    INFO Domain A Lookup Your promos.com A record is:

    promos.com. A 91.xxx.xxx.150 [TTL=86400]
     
  13. falko

    falko Super Moderator

    The MX for fragemporium.net doesn't have an A record:

    Code:
    dig mx fragemporium.net
    
    ; <<>> DiG 9.3.4 <<>> mx fragemporium.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20639
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fragemporium.net.              IN      MX
    
    ;; ANSWER SECTION:
    fragemporium.net.       3600    IN      MX      10 [B][COLOR="Red"]mail200.hoo--yah.com[/COLOR][/B].
    
    ;; Query time: 209 msec
    ;; SERVER: 145.253.2.75#53(145.253.2.75)
    ;; WHEN: Fri May 18 19:18:28 2007
    ;; MSG SIZE  rcvd: 70
    As you see, mail200.hoo--yah.com doesn't exist:

    Code:
    dig mail200.hoo--yah.com
    
    ; <<>> DiG 9.3.4 <<>> mail200.hoo--yah.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 62127
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail200.hoo--yah.com.          IN      A
    
    ;; AUTHORITY SECTION:
    hoo--yah.com.           3600    IN      SOA     dns1.bigapple-isp.net. noc.ns1.bigapple-isp.net. 2004070920 1800 900 604800 3600
    
    ;; Query time: 210 msec
    ;; SERVER: 145.253.2.75#53(145.253.2.75)
    ;; WHEN: Fri May 18 19:18:37 2007
    ;; MSG SIZE  rcvd: 103
     
  14. vassilis3

    vassilis3 New Member


    !!!!!!!!!
    what do you mean?
    this mail address isn't mine!!!!
     
  15. vassilis3

    vassilis3 New Member

    never I send email to this address.
    is it possible to be from spam?
     
  16. falko

    falko Super Moderator

    Yes, that's possible. Please make sure your mail server isn't an open relay.
     

Share This Page