Umlaut problem on ISPConfig3 server

Discussion in 'Installation/Configuration' started by Hans, Apr 9, 2010.

  1. Hans

    Hans Moderator ISPConfig Developer

    On the moment i'm busy to migrate all my websites from my ISPConfig2- to my ISPConfig3 servers.
    Although it's a lot of work, everything goes well until now.

    I've seen that my client used an umlaut on his website. This umlaut, which should be "ü" is displayed as "ü".

    The DefaultCharset has been switched off on Debian Lenny.
    The reason for this might be, that Apache is forced to use the characterset which is used in the header of the websites, like
    "<meta http-equiv="Content-Type" content="text/html;>charset=iso-8859-1" />" for example.

    In my browser, when i switch from iso-8859-1 to utf- encoding, the website appears well, as the "ü" appears well, but that's not what my client wants.

    Can anyone advise me how to solve this problem.
    (Because i did not have problems with my ISPConfig3 servers, my configuration files are still default).
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You might try to set a default charset for this vhost e.g. by using a .htaccess file or add it in the apache directives field of the website.
  3. Hans

    Hans Moderator ISPConfig Developer

    Hi Till,
    I've done the following:
    Within ISPConfig3, i added the following tot the "Options" tab of the website:

    Option: Allow Override: All
    Apache directives: AddDefaultCharset UTF-8

    This works for me!

    Thanks for your help.

Share This Page