UID of script "/var/www/web3/web/index.php" is smaller than min_uid

Discussion in 'Installation/Configuration' started by jonwatson, Feb 6, 2007.

  1. jonwatson

    jonwatson New Member

    Hi all,

    I recently transferred a site from my old host to my ISPConfig installation and I'm getting this error.

    I would have thought that it was referring to the UID of the web3 user, but since ISPConfig doesn't make entries into the /etc/passwd file I don't get it.

    I've also looked at the minimum UID and GID within ISPConfig which are both set to 10000 by default. I can lower them, I guess, but I don't know what to lower them to.

    Any ideas?

    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig makes entries in the /etc/passwd file.

    Which user owns the index.php file and what is his uid?
     
  3. jonwatson

    jonwatson New Member

    Not in mine. I have an adminispconfig use and some users for the various services, but not 'web' users.

    Turns out the min UID and GIDs allowed are stored in /etc/suphp/suphp.conf. It's an SuPHP issue. I changed those numbers and all was good.

    I'm using the ISPConfig appliance so it seems really odd to me that a preconfigured appliance is misconfigured.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    So it's working now? If not, what's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  5. jonwatson

    jonwatson New Member

    Yup, it's working now. I set the min UID and GID to 1. I figured setting it to 0 would be far too dangerous.

    I consider this a workaround rather than a fix. I'll investigate when I have more time and try to get suPHP and ISPConfig working well together.
     
  6. SamTzu

    SamTzu Member HowtoForge Supporter

    min GID & UID

    I had the same issue in the same VM but mine turned out to be a problem with the site file credentials. I had tried to use the /standard_cgis/web/ folder as a skeleton. It worked fine except all the copied files were copied as "root" not as the suPHP user.

    Is there a way to change the owner with a script? The /web folder is user owned but files copied to it are root owned.

    Sam
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You may add some commands to chown the files in /root/ispconfig/scripts/lib/ispconfig.lib.php. the file contains functions that where called when a web is inserted or updated.
     

Share This Page